VLANs Switch "eth1" has an unknown topology

While trying setup VLANs on eth1 I used example switch configuration from https://lede-project.org/docs/user-guide/switch_configuration

Using eth1 instead of eth0

Luci shows this error "Switch "eth1" has an unknown topology - the VLAN settings might not be accurate." at the url /cgi-bin/luci/admin/network/vlan.

I have e1000 intel cards.

dmesg shows 8021q: 802.1Q VLAN support v1.8

So how do I setup VLANs on eth1? I think I'm doing it wrong if I get that "unknown topology" error.

Here is /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'edf1:43f3:ccaa::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth1'

config interface 'wan'
	option proto 'dhcp'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option ifname 'eth0'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'eth0'

config interface 'localhost'
	option proto 'static'
	option ifname 'lo'
	option ipaddr '127.0.0.1'

config switch 'eth1'
	option reset '1'
	option enable_vlan '1'

config switch_vlan 'eth1_1'
	option device 'eth1'
	option vlan '1'
	option ports '0 1 3t 5t'

config switch_vlan 'eth1_2'
	option device 'eth1'
	option vlan '2'
	option ports '2 4t 5t'

config switch_vlan 'eth1_3'
	option device 'eth1'
	option vlan '3'
	option ports '3t 4t'

config switch_port
	option device 'eth1'
	option port '3'
	option pvid '3'

Don't use config switch or config switch_vlan sections, these are solely used for swconfig compatible embedded switch hardware.

If you want to use VLANs, simply use eth1.X in your network configuration, e.g. option ifname 'eth1.100' to make a network use VID 100 tagged packets on eth1.

Getting the same error. Could anyone with a separate vlan show me what his etc/config/network file looks like?
And about dhcp should we just copy the lan section and replace 'lan' on:

config dhcp 'lan'
option interface 'lan'

With the name of our new interface? Followed both the LEDE and OpenWRT and I keep getting the same issue described by hagna231. Already configured guest wifi, all I need now is a port with its own vlan.
Thanks.