VLANs on 1 ethernet port 21.02

Hi.

I have and aruba ap-105 , and flashed it with openwrt. I try to add vlans, but it doesn't work. I don't get an dhcp lease from my dhcp server of my seperate router. It has only 1 ethernet port and 2 radio's

I have my netwoks untagged (primary vlan 99) and tagged vlan 70.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf0:befd:e8b8::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.199.200'
	option netmask '255.255.255.0'
	option gateway '192.168.199.254'
	option ip6assign '60'
	option dns '192.168.180.254'

config interface 'vlan70'
	option proto 'none'
	option device 'eth0'

config device
	option type '8021q'
	option ifname 'eth0'
	option vid '70'
	option name 'eth0.70'
	option ipv6 '0'

Try the following:

Remove the above.

And change the below eth0 > eth0.70

The interface may actually need to be made into a bridge in order to work with the WiFi radios, but that can be done if this doesn’t work.

Hi,

Tried, but still fails. bridge was added while added the interface to the wireless radio

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf0:befd:e8b8::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.199.200'
	option netmask '255.255.255.0'
	option gateway '192.168.199.254'
	option ip6assign '60'
	option dns '192.168.180.254'

config interface 'vlan70'
	option proto 'none'
	option device 'eth0.70'
	option type 'bridge'

The use of option type bridge in an interface section is deprecated. Make a separate bridge device named br-vlan70 (like br-lan) and use it as the device of interface vlan70. Initially it will have only one member but specifying option network vlan70 in /etc/config/wireless will add the AP to it.

brctl show can be used to show the bridges that were created in the kernel.

Like this? It doesn't work yet. Must I set somewher the vlan id 70?

config device
	option name 'br-vlan70'
	option type 'bridge'
	list ports 'eth0'

config interface 'vlan70'
	option proto 'none'
	option device 'br-vlan70'

root@OpenWrt:~# brctl show
bridge name	bridge id		STP enabled	interfaces
br-lan		7fff.24dec6c29988	no		eth0
br-vlan70		7fff.24dec6c2998a	no		wlan1

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option encryption 'psk2'
	option key 'secret ofcourse'
	option ssid 'ap-105test'
	option network 'vlan70'

The port in br-vlan70 would be eth0.70 not eth0.

1 Like

Thnx that is the solution

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.