VLAN trunk on EA8300?


Has anyone managed to get a VLAN trunk working on a EA8300 device?

I see plenty of posts talking about how the switch is "strange", however none of them have a working configuration for a trunk...

I can mark a port as tagged in /etc/config/network, and swconfig shows this, however nothing is ever transmitted out.

I'm wondering if I'll need to wait for DSA for this device in order to do this?


I don't have an EA8300, so I can't help you with the nuances of that device...

What version of OpenWrt are you using?
What is downstream of the EA8300 on the port(s) that you are setting with tagged networks? Are they VLAN aware and configured properly?
What VLAN IDs are you using?

It would be good to share your /etc/config/network file for review.

I'm using the latest snapshot from yesterday (as apparently there have been patches applied for this problem since 21.02).

The downstream switch is VLAN aware and working (I run other trunked devices on it, and even swapped ports with a working one to confirm).

Let me post the config file when I get back home later on.

This is the tail output of swconfig dev switch0 show that has the "strange" VLAN 1 and 2 auto created by the driver, as well as the two VLANS I use of 10 and 20.

Port 4 is setup as the trunk, but fails to send/receive traffic. This is my problem.

        vid: 1
        ports: 0t 1t 2t 3t 4 
        vid: 2
        ports: 0t 5 
        vid: 10
        ports: 0t 1 2 4t
        vid: 20
        ports: 0t 3 4t 

Here's the /etc/config/network file, the bridge devices are used for adding two different wifi interfaces "lan" and "guest".

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '10'
        option ports '0t 1 2 4t'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '20'
        option ports '0t 3 4t'

config interface 'lan'
        option proto 'static'
        option netmask ''
        option gateway ''
        option ipaddr ''
        list dns ''
        option device 'br-lan'

config interface 'guest'
        option proto 'none'
        option device 'br-guest'

config device
        option type 'bridge'
        option name 'br-lan'
        list ports 'eth0.10'
        option bridge_empty '1'

config device
        option type 'bridge'
        option name 'br-guest'
        list ports 'eth0.20'
        option bridge_empty '1'

Finally I can see the bridge is up and "forwarding", and I can send/receive traffic between ports 1 & 2 on VLAN 10 just fine.

# brctl showstp br-lan
 bridge id              7fff.149182ad14b8
 designated root        7fff.149182ad14b8
 root port                 0                    path cost                  0
 max age                  10.00                 bridge max age            10.00
 hello time                1.00                 bridge hello time          1.00
 forward delay             8.00                 bridge forward delay       8.00
 ageing time             300.00
 hello timer               0.00                 tcn timer                  0.00
 topology change timer     0.00                 gc timer                 158.48

eth0.10 (1)
 port id                8001                    state                forwarding
 designated root        7fff.149182ad14b8       path cost                  4
 designated bridge      7fff.149182ad14b8       message age timer          0.00
 designated port        8001                    forward delay timer        0.00
 designated cost           0                    hold timer                 0.00

Ditto ip link shows eth0, eth0.10@eth0 and br-lan all "UP".

Did you try this ?

1 Like

Just tried it, and ... it all works. Wonderful!

Fun fact is that I haven't try it myself ... yet.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.