Vlan tags on untagged switch

With a packet capture I didn't see them. But when disabling the 802.1q module the number of dropped packets increased steadily. That behavior is gone now. I disabled 802.1q on all Debian machines and the steady increase of dropped packets on those machines has stopped.

So that basically means this issue is solved.