VLAN tagging problem

env:
I do have a installation with a Linksys wrt1200ac Openwrt v.19.07.3 this is working with VLAN tagging perfect without any problem.
If I am replacing the Linksys wrt1200ac with a Netgear R6220 with Openwrt v.21.0.2 then the VLAN tagging is only working partial.

desc:
If I am using the Netgear R6220 v.21.02.1 then I have always problem with the VLAN1 configuration.
The configuration for the VLAN3 (bridge.3) is working perfect without any problem.
I did try several option but as soon as I try to make a correct VLAN1 configuration then it gets complete wrong.
After that I have to restore the Openwrt v.21.02.1 to get readay again.
I have no idea what went wrong with my configuration for the VLAN1.
lan1 = untagged
lan2 = untagged
lan3 = VLAN1 and VLAN3 tagged
lan4 = untagged

Here the running configuration ( Linksys wrt1200ac v.19.07.3 ) VLAN tagging works for VLAN1 and VLAN3

...
...
config interface 'lan'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '10.0.70.100'
	option netmask '255.255.255.0'
	option ip6assign '60'
...
...
config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '5t 3 2 1t 0'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 4'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '5t 1t'
	option vid '3'

config interface 'TV'
	option ifname 'eth0.3'
	option proto 'static'
	option ipaddr '10.0.80.100'
	option netmask '255.255.255.0'

Here the not running configuration ( Netgear R6220 v.21.02.1) VLAN tagging works only for VLAN3

...
...
config interface 'lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '10.0.70.100/24'
        option broadcast '10.0.70.255'
        option device 'bridge'
        option gateway '192.168.1.1'
...
...
config device
        option type 'bridge'
        option name 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option vlan_filtering '0'

config interface 'TV'
        option proto 'static'
        option ipaddr '10.0.80.100'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option broadcast '10.0.80.255'
        option device 'bridge.3

config bridge-vlan
		option device 'bridge'
		option vlan '1'
		list ports 'lan1'
		list ports 'lan2'
		list ports 'lan3:t*'
		list ports 'lan4'

You have to convert the network to DSA.

With the installation of the Openwrt v.21.02.1 I get the DSA code.
How do I convert the network ?
If you look at the v.21.02.1 configuration there you can see that I already have the "bridge" configuration this is DSA style configuration. I did config the bridge sections and I did try to make it similar to the v.19.07.3 but without success

Declare two bridge-vlan on the bridge, one with vlan number 1 and one with number 3. Connect the lan network to bridge.1 and the TV network to bridge.3

This needs to be 1 because you are going to run VLANs in the bridge.

Yes thank you for the tip.

I did the change the configuration and it seems to be working now.

I did change/insert the followings:
In the "config interface lan" from bridge to bridge1
In the "config interface TV" nothing
in the "config device" option vlan_filtering from 0 to 1
In the "config bridge-vlan" vlan from option vlan 3 to 1
In the "config bridge-vlan" adding :u* to all the other lan's
Plus a complete new "config bridge-vlan" for the vlan3

config interface 'lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '10.0.70.100/24'
        option broadcast '10.0.70.255'
        option device 'bridge.1'
        option gateway '192.168.1.1'
		
config interface 'TV'
        option proto 'static'
        option ipaddr '10.0.80.100'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option broadcast '10.0.80.255'
        option device 'bridge.3
...
...
config device
        option type 'bridge'
        option name 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option vlan_filtering '1'

config bridge-vlan
		option device 'bridge'
		option vlan '1'
		list ports 'lan1:u*'
		list ports 'lan2:u*'
		list ports 'lan3:t*'
		list ports 'lan4:u*'
		
config bridge-vlan
		option device 'bridge'
		option vlan '3'
		list ports 'lan3:t*'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.