VLAN tagging on ipq40xx (GL-B1300) no longer works

Thx, but cannot use your patch, because it is against master. I will have to wait until the issue is fixed in 19.07.

The ipq40xx ethernet vlan double tagging patch from July 14 in the latest snapshot may have fixed something else, but I too can report it has broken the vlan I have assigned to physical port 4 of my EA6350 AP to segregate my Ooma VOIP box from the home lan. A wireless interface using the same VLAN on this router works, but not the physical port. Oh well - such are the risks of flashing the latest snapshot. I'll be dropping back to 19.07.3 stable. I've added my switch configuration below for reference.

Edit: Plugging the Ooma into physical port 3 (assigned to the default lan interface) and power cycling got the Ooma back on the internet. I think I'll find trusting the Ooma on my home lan easier than flashing 19.07.3 to get the vlan back on port 4 for now.

config switch                                                                   
        option name 'switch0'                                                   
        option reset '1'                                                        
        option enable_vlan '1'                                                  
                                                                                
config switch_vlan                                                              
        option device 'switch0'                                                 
        option vlan '1'                                                         
        option ports '1 2 3 0'                                                  
                                                                                
config switch_vlan                                                              
        option device 'switch0'                                                 
        option vlan '3'                                                         
        option ports '0t 1t'                                                    
        option vid '10'                                                         
                                                                                
config switch_vlan                                                              
        option device 'switch0'                                                 
        option vlan '4'                                                         
        option ports '0t 1t'                                                    
        option vid '20'                                                         
                                                                                
config switch_vlan                                                              
        option device 'switch0'                                                 
        option vlan '5'                                                         
        option ports '0t 1t 4'                                                  
        option vid '30'                                                         
                                                                                
config switch_vlan                                                              
        option device 'switch0'                                                 
        option vlan '6'                                                         
        option ports '0t 1t'                                                    
        option vid '40'                                                         
                                                                                
config interface 'GST'                                                          
        option proto 'dhcp'                                                     
        option ifname 'eth0.20'                                                 
        option type 'bridge'                                                    
                                                                                
config interface 'IOT'                                                          
        option proto 'dhcp'                                                     
        option ifname 'eth0.30'                                                 
        option type 'bridge'                                                    

Add port 5 to the config.

I am using this config to bridge port 4 to wan.

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 1 5'

What is port 5? Is it possible to make my config work? I just need to isolate my two LAN ports.

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '3 0t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '4 0t

So add port 5 there.

option ports '3 0t 5'

See IPQ40xx Switch Config "Strangeness"

1 Like

Can elaborate on what that would do? Do you suggest I add port 5 to both VLAN's?

I don't remember exactly how it works, because I was struggling with that long ago. Try to add to one first. I gave a link to the old discussion.

See also Setting up VLAN on AVM Fritz!Box 4040 not working

1 Like

But as soon as you try to change something in Luci, port 5 will be removed.

1 Like

Maybe try my build for FB4040 ? (19.07.3)


Or build your own, based on the information provided ...
I'm glad to got it working on 19.07 but I have no idea where kernel 5.x will lead us to.

Cheers,
Thomas

Adding port 5 to one or both ports did not fix the issue.

Thx, but I am trying to get out of business of building my own firmware. I am hoping that the issue will be fixed. I can wait.

No luck for me adding port 5 to the config either Pilot6, but thank you for the suggestion. Since the VOIP box is working plugged into a port on the main lan, I think I'll just leave it there and save my debug time for DSA when it replaces swconfig.

Edit: And...the 5GHz wifi interface lost access to the VLAN today, so I flashed 19.07.3 stable to the EA6350 and all is good. I can't say I wasn't warned - the Downloads page clearly advises not to experiment with snapshot for a main home device. Did I listen? Of course not!

@blogic is there a chance you can look into the commit https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=8c191712558ce945993982b03abc5ce80e0fe230 that broke VLAN in ipq40xx ?

show me your config. the switch basically allows you to do vlaning from netdev rather than having to play with the switch config

1 Like

This is it. It used to give me eth1.3 and eth1.4 so that I can create interfaces for them.

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '3 0t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '4 0t'

related post.

I have a similar problem with my Aruba InstantON AP11 / AP-303.

This device does not have an internal switch, it just has a single ethernet port. Software VLANs (eth0.10 and the like) are not working with latest master, the only thing that reaches the software VLAN interface is DCHP, ICMPv6 and ARP traffic, nothing else.

config interface 'v10'
	option proto 'none'
	option type 'bridge'
	option ifname 'eth0.10'

I usually bridge the software VLAN interface with a wifi-iface (to bind seperate SSIDs to individual VLANs):

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'sae'
	option key 'XXXXXXXXXXXXXXXXXXXXXXX'
	option wpa_disable_eapol_key_retries '1'
	option network 'v10'

I am running a GliNet B1300 with stock OpenWRT and need to add tagging a seperate VLAN. Shall I wait until the dust comes down?

Any tips on how to make it work again?