Vlan tagging in B1300 in WAN port

yes, I did put the number of the vlan id, not the xxx

Is everything else set up as required by your ISP? Restarted the interface?

the only required thing is to have the wan port tagged on a specific vlan. the ip is given by dhcp. The authentication is done by a fiber ONT device.

He recommends to use software-level (driver-level) vlan, as it is stated in the end of OpenWRT-manual about switch above. However now I have enough experience to be ready for some unexpected behavior like this. In firewall configuration also there are unexpected tips, and furthermore, they are not specified in any manual!

Sorry, I misread the labels on the image.

Your router has the same problem as described here

Post your current network config, and the logs from a failed connection.

@xcarituti You need to use LAN port as WAN to tag it. The config below is defining one of the LAN ports (the opposite from WAN) as WAN and tags it with VLAN 35 and the other LAN port is VLAN 4. The original WAN port is used as LAN in this setup.

config interface 'wan'
        option ifname 'eth0.35'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '35'
        option ports '3t 0t'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '4'
        option ports '4 0t'

1 Like

The only quirk is that VLAN's 1 & 2 are reserved, but otherwise one can easily use VLANs on this router (and probably on all ipq400xx) on LAN ports as long as reserved VLAN's are not used. No code modifications are required.

(sorry, I was locked out of posting on my account for excess replies in my first day)

this is a software vlan or a hardware vlan? from the syntax (eth0.x) appears to be a software vlan. should I prefer this over hardware vlan?

I d not know the difference, but that works on an ISP line that requires VLAN tagging.

hi @xcarituti

I also am in the process of configuring VLAN's on my brand new B1300 from GL.inet

We can help each other... Have you been able to set this up correctly ?
My Ethernet WAN port is being blocked., the moment I enable VLAN.

My current WAN uplink from this router is to another router running openwrt.
I mostly plan to use the wireless network and have some NAS devices over the ethernet, and also connect another B1300 or S1300 for more wifi coverage to the other one...

G

1 Like

hi @fantom-x / Marc

I really need to get this working... Please post only if you have this working on your B1300

Can anyone post a working /etc/config/network with a configured switch config.

and also dump their
swconfig dev switch0 show

G

hi,

Just FYI, I seem to have this working however I am still a bit confused... I have to do this over commandline and luci wont work.

I also had to do a factory reset to get the stuff I wanted to work...

I am still not done with everything so I will keep updating the thread... if someone needs help on this, let me know I can share my experience.

I have a netgear GC108P hooked to one of the lan ports, and am running a main-vlan, (LAN), a home-automation-VLAN-subnet and a guest-VLAN-subnet, and trying to configure the 7 available ports on the switch(GC108P) to different networks

G

1 Like

WAN port VLAN is also not configurable trough Luci on my hAP ac2 (IPQ4018).

PD: VLAN tagging is done on my ISP ONT so I don't need it but just wondering if it's possible.

Can you share your VLAN tagging for WAN solution?

See my comment above, and comment it.

Can you your switch and interface configs?

Which hardware do you have? If it's a B1300 you would only need to change "eth1" to "eth1.10" in the wan section, since eth1 does not pass through any switch.

And that will tag all outgoing packets with PVID 10 and also accept incoming packets tagged with VID 10? I cannot test that at the moment, but I remember trying that and the router would not establish a PPPoE session with my ISP. I will try this again in a week or so.
I am using B1300.