Vlan tagging driver level

I had asked this before but the thread is now closed, I initially had a dumb switch but just today got a TP-Link 108PE for my EAP245 and some future PoE stuff, it was said this would pass my vlan tags. I have setup a driver level vlan, I am using a 8devices Jalapeno as my router.

The config I have is:

config interface 'lan10'
        option type 'bridge'
        option ifname 'eth0.10'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '64'
        option ip6hint '1'

I have enabled DHCP and set wireless vlan in the tp-link cloud controller to 10, on OPNsense and Pfsense this works even with my dumb switch, what am I doing wrong here?

Eth0 is my LAN so as I am reading I need to do eth0.10 to tag all traffic?

Now for this switch right now I cannot access the device as I have no windows machines to install there software.

Yes, correct.

You can connect with your browser. ( I suppose it is the SG108PE)

Is the default for connect ip That is the model.

It should be

OK I'll try again I was unable to access I set a static IP of but it just hangs will try again.

By default no vlan is configured and all ports are untagged on vlan1.

Ahh, i was being stupid, the instructions say my router will give it an IP which it did. Thanks!

So I got in and tagged port 1 and 8 which is my lan from my jalapeno and 8 which is my eap245 for vlan id 10 per my config above but I do not ever get a dhcp address. I have enabled dhcp on this interface.

Not sure why this is happening, any tips?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
iptables-save -c; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \