Vlan setup not working

I own a Linksys WRT1900ACS. I was trying to set up a vlan and a wifi in that vlan.
But there is something wrong in my config. Furthermore everytime I add a virtual interface I have to reconnect the wan interface otherwise the internet is not working. My test device receives an IP from the range I assigned the dhcp server to. But the firewall rules are not working as it does not have internet connection. And the gateway is on 10.0.10.1 but the router is pingable from vlan10 pinging 10.0.0.1

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd14:a560:8793::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.0.0.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '5t 3 2 1 0'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '6t 4'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'static'
        option ipaddr '192.168.1.100'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '1.1.1.1 8.8.8.8'

config interface 'vlan10'
        option ifname 'eth0.10'
        option proto 'static'
        option type 'bridge'
        list ipaddr '10.0.10.0/24'
        option gateway '10.0.10.1'

Firewall

config zone
        option network 'vlan10'
        option input 'ACCEPT'
        option name 'vlan10'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config forwarding
        option dest 'wan'
        option src 'vlan10'

Wifi

config wifi-iface 'wifinet2'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'ap'
        option network 'vlan10'
        option key 'test1234'

Change it accordingly:

The IP was invalid. Gateway is not needed here. You have not configured a vlan10 on the switch, hence you can configure it as wifi only.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.