VLAN setup help

Wan 6 is kinda useless to me anyways, my ISP doesn't support ipv6

for some reason if Lan interface doesnt use br-lan.1 it doesnt work, i cant obtain an ip address

also weirdly cant access LuCI on my mx4200 even tho i havent touched it yet

my latest config for bpi r4

It's not so weird. I told you to use native vlan untagged on lan3 of BPi and you used tagged.

oh ok, ill do that now

BusyBox v1.36.1 (2024-12-23 00:55:35 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 24.10.0-rc4, r28211-d55754ce0d
 -----------------------------------------------------
root@bpi:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd38:7784:d57b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'wan'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth2'
        option macaddr ''

config interface 'wan'
        option device 'eth2'
        option proto 'pppoe'
        option username ''
        option password ''
        option ipv6 'auto'
        option keepalive '0 1'

config interface 'wan6'
        option device 'eth2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option norelease '1'

config device
        option type 'bridge'
        option name 'br-guest'
        option bridge_empty '1'

config interface 'guest'
        option proto 'static'
        option device 'br-guest'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option defaultroute '0'

config interface 'cctv'
        option proto 'static'
        option device 'eth1'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option defaultroute '0'

config interface 'wg0'
        option proto 'wireguard'
        option private_key ''
        option listen_port '51820'
        list addresses '192.168.5.1/24'

config interface 'alarm'
        option proto 'static'
        option device 'lan3'
        option ipaddr '192.168.4.1'
        option netmask '255.255.255.0'
        option defaultroute '0'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'wan'

config bridge-vlan
        option device 'br-lan'
        option vlan '4'
        list ports 'lan3:t'

config wireguard_wg0
        list allowed_ips '192.168.5.2/32'
        option route_allowed_ips '1'
        option persistent_keepalive '25'

config wireguard_wg0
        option route_allowed_ips '1'
        option persistent_keepalive '25'
        list allowed_ips '192.168.5.3/32'

config wireguard_wg0
        option preshared_key ''
        list allowed_ips '192.168.5.4/32'
        option route_allowed_ips '1'
        option persistent_keepalive '25'

root@bpi:~#

So like this?

I showed you this:

and you show me this.

I'd love to help, but my time is limited and I cannot troubleshoot further what you improvise instead of doing what we ask you.

1 Like

sorry for the annoyance and inconvenience, im just a bit confused, i understand it now, im a complete noob at vlan

I've done it now, I didn't understand what you meant by native untagged originally but I understand it now

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3:u*'
        list ports 'wan'

config bridge-vlan
        option device 'br-lan'
        option vlan '4'
        list ports 'lan3:t'

That's what I have now

Ok yeah that worked, I got access back to the mx4200

BusyBox v1.37.0 (2024-12-28 13:54:51 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r0-a1bbf95
 -----------------------------------------------------

 OpenWrt recently switched to the "apk" package manager!

 OPKG Command           APK Equivalent      Description
 ------------------------------------------------------------------
 opkg install <pkg>     apk add <pkg>       Install a package
 opkg remove <pkg>      apk del <pkg>       Remove a package
 opkg upgrade           apk upgrade         Upgrade all packages
 opkg files <pkg>       apk info -L <pkg>   List package contents
 opkg list-installed    apk info            List installed packages
 opkg update            apk update          Update package lists
 opkg search <pkg>      apk search <pkg>    Search for packages
 ------------------------------------------------------------------

For more https://openwrt.org/docs/guide-user/additional-software/opkg-to-apk-cheatsheet

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde2:cc50:9d0d::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'dhcp'
        option force_link '1'

config interface 'alarm'
        option proto 'none'
        option device 'br-lan.4'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1'
        list ports 'lan3:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '4'
        list ports 'lan2:u*'
        list ports 'lan3:t'

root@OpenWrt:~#

(Linksys MX4200)
@trendy is this it

Alright, and what is not working with the current setup?

Everything seems to work, except for the alarm itself, I cannot connect to it, even though the BPI R4 says it has an IP address ending in 4.X

yeah wireless ap doesnt work too on the mx4200 only found out when i changed the ssid and tried to connect to it, it does not authenticate, but i can access the LuCi interface though

Happy new year!

If you still have defaultroute=0 then it is expected.

This is confusing. Authentication takes place on mx4200. After that it should get DHCP settings from BPi.
Post the latest configs from both to verify:

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru

Most likely you won't need to paste in pastebin for this one.

Happy New Year to you too,

Put it in pastebin just in case

MX4200

BPI R4

ah yes forgot todo this, but even after doing still cant get a connection to it

hmm pinging the router from lan results in

Reply from 192.168.1.1: Destination host unreachable.

When Trying to connect wirelessly to the mx4200 logs say IEEE 802.11: deauthenticated due to local deauth request

For the mx4200 change the encryption to none and try again. If it works, use wpa2.

Does the mx4200 get IP from BPi DHCP?
Does the alarm get IP from BPi DHCP?

Which device is pinging the router and fails? Where is it connected? Does it get settings from DHCP?

My laptop can't ping the alarm, but I can ping the mx4200 from the laptop just fine,

Both the alarm and mx4200 get an IP address from the BPI thats what I can see in LuCI