VLAN setup for Banana Pi R3 Dumb AP

Hi everyone,
I hope this is the right place to post this question. I have a Banana Pi R3 running OpenWRT 23.05, and I am trying to set up VLANs. However, it seems that newer versions of OpenWRT have changed the method for configuring VLANs.

The guides I’ve found suggest going to Network > Switch in LuCI, but I don't have this option in the interface. My goal is to create 4 VLANs: 10, 20, 30, and 40. Specifically, I want to configure the following:

  • SSID Setup:
    • Home (VLAN 10 port 1)
    • Guest (VLAN 30 port 2)
    • IOT (VLAN 20 port 3)
  • VLAN 40 will be for my server network (Ethernet-only on port 4).

I also want to use my WAN port as a trunk and have the router configured as a dumb AP connected to my OPNsense firewall through this trunk. I am using Openwrt as a VLAN aware access point and switch connected to my OPNsense firewall which acts as the primary gateway device.

Here is my current configuration:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd0:350f:2198::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'sfp2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'br-wan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'wan'

config device
	option name 'eth1'
	option macaddr '0e:7c:5e:fc:a9:be'

config device
	option name 'wan'
	option macaddr '0e:7c:5e:fc:a9:be'

config interface 'wan'
	option device 'br-wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'br-wan'
	option proto 'dhcpv6'

I found the guide on how to setup OpenWRT as a dumb AP and I got it working, but then I started messing with the VLANs and I broke the config many times throughout the past few days. DNS is broken only when I have the Banana Pi plugged into OPNsense, it works when I plug it in to an ISP Calix router. I'm not sure why that is happening, but I will post that on the OPNsense fourms since it is likely an OPNsense issue.