VLAN results in two interfaces with the same link-local IPv6 address, is that ok?

My br-lan uses port eth0, and my br-guest uses port eth0.2, this results in them having the same mac address and thus the same link-local IPv6 address, I wonder if this can cause problems down the road or I should manually specify a different mac for one of them?

Something smells wrong here... can you post your network and wireless config files, please?

Thanks for the quick reply.

This is the minimal config to reproduce (It's a x86 pc with no wireless), with master openwrt:

/etc/config/network

...

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'

config device
	option name 'br-guest'
	option type 'bridge'
	list ports 'eth0.2'

config interface
	option device 'br-guest'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '64'

After /etc/init.d/network restart, this is what ip addr returns:

13: br-guest: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether <identical mac address> brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-guest
       valid_lft forever preferred_lft forever
    inet6 fd00:0:1::1/64 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 <identical link-local IPv6 address> scope link
       valid_lft forever preferred_lft forever

15: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether <identical mac address> brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd00:0:1:1::1/64 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 <identical link-local IPv6 address> scope link
       valid_lft forever preferred_lft forever

<identical mac address> is eth0's mac address, and <identical link-local IPv6 address> is generated from <identical mac address>.

I guess both br-lan and br-guest take mac address from the first underlying port?

That's 100% OK, because the link-local IPv6 address must only be unique within the broadcast domain, and each VLAN creates its own broadcast domain.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.