VLAN Problem with new 23.05.0-rc3

Hi, i have been using Openwrt since 2020 for my "dumb" AP Setups. I recently (around April 23) switched to new WIFI6 APs (D-Link DAP X1860) and installed Openwrt as OS. Everything worked fine with my current config until i wanted to update to the newes RC (23.05.0-rc3). It seems that my Wifi-Clients can connect to the AP but dont get any ips assigned.

My network setup is like this:
WLAN-AP -> pfSense (DHCP Server)
There is one VLAN (16) for my Clients. The AP is accessable through his own address.

/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdcd:b3cc:2792::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '172.30.0.21'
        option gateway '172.30.0.254'
        list dns '172.30.0.254'
        list dns_search 'local'

config device
        option name 'br-vlan16'
        option type 'bridge'
        list ports 'lan.16'

config interface 'vlan16'
        option device 'br-vlan16'
        option proto 'none'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/xxxxx'
        option band '2g'
        option htmode 'HT20'
        option channel '11'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci00xxxx'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'fw'
        option wpa_disable_eapol_key_retries '1'
        option key 'xxxxx'
        option network 'vlan16'
        option encryption 'psk2+ccmp'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'fw5'
        option key 'xxxxx'
        option wpa_disable_eapol_key_retries '1'
        option encryption 'sae'
        option network 'vlan16'

Can you help me finding the mistake i am making?

This is likely your problem...

Try using the bridge VLAN DSA syntax here. Remove the device statement above, then add these thigns:

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '16'
	list ports 'lan:t'

Now, edit the network interfaces so that lan uses br-lan.1 and vlan16 uses br-lan.16

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '172.30.0.21'
        option gateway '172.30.0.254'
        list dns '172.30.0.254'
        list dns_search 'local'

config interface 'vlan16'
        option device 'br-lan.16'
        option proto 'none'

Restart your router and try again.

Ok, will try that. But why does my old config work with the current official release (22.05.03) and stops working with 23.xx? Is the old syntax Not supported anymore?

EDIT your config works! Thx a lot :slight_smile: can u pls still explain me why my old config doesnt work anymore with the newer releases?

Many devices are converted for DSA in 23.x.x.x.

1 Like

All devices that contained internal switches running on OpenWrt 19.07 and earlier used swconfig for managing the switch. Starting with 21.02, OpenWrt has been migrating to DSA ("distributed switch architecture"), a few targets/platforms at a time. This is a completely different paradigm and method of addressing the internal switch chip, and it uses a completely different syntax. As such, when a given platform is transitioned to DSA, the old swconfig syntax no longer works and reconfiguration from scratch with the new method is required. Your device is likely in the 3rd wave of DSA transitions (21.02 had the first set of targets, followed by more in 22.03, and now 23.05) which is why you were able to use the old style config previously but now must use DSA.

3 Likes

This doesn't really compute, support for the DAP-x1860 is new - there never was an older OpenWrt version for it and its support in OpenWrt was DSA based from the start in master in early january of this year.

2 Likes

Thx for the explanation. Would the conversion be done automatically from the next official release or would I still have to do it manually?

@slh
I just can tell you that if i go to the firmware selector and choose the 22.03.5 release my old config works 100%. I did that a lot today :smile:
As soon as i upgrade to 23.xx it stops working. This fits exactly with what psherman and mattimat have said…

There is no conversion involved for this particular hardware of the dap-x1860, it never used anything but this very same DSA configuration.

Hi thanks for the hint I was also lost how to configure VLANs. Unfortunately this does not solve all my issues. I had a config like this:

Each of the interfaces had a wireless network assigned. Now - without a bridge anymore - it looks like the wireless network does not get connected to the VLAN. :frowning:

They are bridges... that is the purpose of the bridge vlan.

I'm confused, though -- you said earlier that the config I suggested worked, but now it's not working?

Let's take a look at your latest config files.

I will try once again. At least I was able to get interfaces connected to the corresponding VLANs and I was e.g. able to retrieve IPs via DHCP.

That sounds like it is working as expected, unless I am missing something. Was there a specific problem?

I think you got confused because Alex kind of hijacked my thread :smile: for my setup everything is fine and works!

Ah.. .yes... I didn't catch that this was 2 parallel conversations.

@alexf2015 - care to make a new thread where we can work on your issue?

looks like my issues are solved, too

Great! Glad to hear it!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.