Vlan problem? Guest network not working on Pi4 / worked on my wrt3200acm

Former situation:

• Wrt3200acm – OpenWrt 19.07-SNAPSHOT
• Guest network on vlan id 3 (configured in Luci switch)
• Linksys Velop AP’s Wifi and Guest wifi are configured on this AP’s (Velop uses vlan id 3 for guestnetwork)

New situation:

• Raspberry Pi4b – OpenWrt 21.02-SNAPSHOT
• Tp-link sg105E managed switch
• Guestnetwork on vlan id 3 (configured in /etc/config/network)

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd58:122c:b677::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.0.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0.1'
	option peerdns '0'
	list dns '84.200.69.80'
	list dns '84.200.70.40'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth0.2'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config interface 'vpnclient'
	option proto 'none'
	option ifname 'tun0'

config interface 'guest'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ifname 'eth0.3'
	option ipaddr '192.168.3.1'
	list dns '10.0.1.1'
	option type 'bridge'

• Linksys Velop AP’s Wifi and Guest wifi are configured on this AP’s (Linksys Velop uses vlan id 3 for guest network)

I did configure the vlan id 3 on the wrt3200acm in the switch page on luci, the Raspberry pi 4b doesn’t have a switch page on luci, I assume because it had only one ethernet port. So I configured it in /etc/config/network.

Do I have to add a vlan id 3 on my managed switch? But then it has to go through the same port as my normal lan. (the wifi AP’s are on this port) If that’s the case, I have no idea how to do that :wink:

My sg150E switch setting at this moment;

Port 1 isp bridged modem
Port 2 ethernet port Raspberry Pi 4b
Port 3, 4, 5 my LAN network (wired and wired nodes for my normal en guestwifi)

You are already trunking VLANs 1 and 2 on port 2, you just need to add VLAN 3, tagged on port 2 and any port where your APs are connected.

2 Likes

Yes! thank you very much, I was thinking way to difficult :wink:

1 Like