Hi,
This is my current setup.
I use asus RT-AX88U Pro router as a gatweay for internet. On Asus I created VLAN ssid. My main local wifi router is running openwrt current stable version and is running as wds ap. As i never before set up VLAN I connected my wds ap with another lan cable to asus router and use that connection as my trunk port.
Dhcp is done on asus router. All openwrt routers are just dumb ap or transparent bridges, if I got terminology correct.
On wds ap I created, for testing purposes, ssid and connected my phone to it. My phone got 192.168.10.x address that is address pull for vlan id.
So far so good. VLAN is working between asus and wds ap.
I have few wds clients running openwrt connected to wds ap.
I would like to make VLAN working over wds wifi backhaul but I'm lost there.
It is not that difficult to set up VLAN when you have router to router ethernet connection but as I'm not experienced enough with VLAN setup I find it very difficult to set it up over wds and I didn't found a way to do it.
This is my wds ap config
/etc/config/network
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.8.2'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.8.1'
list dns '192.168.8.40'
config device
option type 'bridge'
option name 'VLANS'
list ports 'lan5'
list ports 'VLANS.10'
list ports 'VLANS.20'
list ports 'VLANS.30'
config bridge-vlan
option device 'VLANS'
option vlan '10'
list ports 'VLANS.10:t'
config bridge-vlan
option device 'VLANS'
option vlan '20'
list ports 'VLANS.20:t'
config bridge-vlan
option device 'VLANS'
option vlan '30'
list ports 'VLANS.30:t'
config interface 'VLAN10'
option proto 'static'
option device 'VLANS.10'
option ipaddr '192.168.10.2'
option netmask '255.255.255.0'
/etc/config/wireless
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid ''
option encryption 'psk2'
option key ''
option wds '1'
option ifname ''
On wds client I have the following setup
/etc/config/network
config device
option name 'br-lan'
option type 'bridge'
option bridge_empty '1'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.8.5'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.8.1'
list dns '192.168.8.1'
/etc/config/wireless
config wifi-iface 'wifinet3'
option device 'radio0'
option mode 'sta'
option network 'lan'
option ssid ''
option encryption 'psk2'
option key ''
option wds '1'
option ifname 'WDS-Client'
I don't understand how to set up VLAN over wds link. If someone did it and can share his config or can point me in right direction on how to do it, I will appreciate it.