VLAN on WAN not working?

Now I found the solution here:

The trick is to add the switch vlan config in /etc/config/network:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 4t'

config switch_vlan
        ### repeat for each vlan ###

and then to use eth0.X as physical device in the interface.

Best regards,
Jonny007