VLAN not working

Hi All,

I have a VLAN3 in addition to the delaut VLAN1. All configured VLANS are working when the client set the VLANid. I have an AP which serves differt SIDs on differt VLANs and that all works fine.

The challenge is that I want one physical port to be on VLAN3.

Hers is what I have got so far but I do not get the physical connection to get a DHCP address from VLAN3.

root@turris:/etc/config# bridge v show dev lan15
port vlan ids
lan15 1 Egress Untagged
3 PVID Egress Untagged

root@turris:/etc/config# bridge v show dev lan15.3
port vlan ids
lan15.3 1 Egress Untagged

As I understand it is that all traffic is arriving on lan15, the PVID set the VLAN tag for all untagged traffic to 3 which then should be send to lan15.3 which has DHCP configured etc. On the way back the tag is removed and send back to the client.

root@turris:/etc/config# cat network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd11:2a2f:dc25::/48'

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
option ipv6 '1'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option _turris_mode 'managed'
option ip6assign '60'
option bridge_empty '1'
option ifname 'lan1 lan10 lan11 lan12 lan13 lan14 lan15 lan16 lan2 lan3 lan4 lan5 lan6 lan7 lan8 lan9'

config interface 'guest_turris'
option enabled '1'
option type 'bridge'
option proto 'static'
option ipaddr '10.111.222.1'
option netmask '255.255.255.0'
option bridge_empty '1'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config interface 'LAN3'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option type 'bridge'
option dns '192.168.3.1'
option ifname 'lan1.3 lan10.3 lan11.3 lan12.3 lan13.3 lan14.3 lan15.3 lan16.3 lan2.3 lan3.3 lan4.3 lan5.3 lan6.3 lan7.3 lan8.3 lan9.3'

config interface 'LAN8_DMZ'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.8.1'
option netmask '255.255.255.0'
option ifname 'lan1.8 lan10.8 lan11.8 lan12.8 lan2.8 lan3.8 lan4.8 lan5.8 lan6.8 lan7.8 lan8.8 lan9.8'

config interface 'LAN2_IOT'
option type 'bridge'
option proto 'static'
option ifname 'lan1.2 lan2.2 lan3.2 lan4.2'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'

Any suggestion will be greatly appreciated.

Could you post your entire /etc/config/network config but remove any passwords please? You can paste your config file between two code blocks like this:-

[code]
code goes here
[/code]

Also is it possible to upload a screenshot of the Network > Switch page, of course if you have LuCI.

Any VLANs should be tagged on the CPU. For a physical ethernet port to connect to a VLAN the port should be set to untagged.

As you can in this screenshot VLAN 5 is my main LAN. I have a tagged port on port 1 as this is for a VLAN trunk with VLAN 10 to another switch. However, the important bit here is I have port 2 and 3 set to untagged so I can still physically connect devices to the router.

Your interface names (ifname) statements in your config file appear very unusual. Did you modify them?

What device is this? And what version of OpenWrt?

Can you also post the contents of /rom/etc/config/network