VLAN issue with wired ports on Linksys E7350

Having an issue with VLAN tagging of the wired switch ports on a Linksys E7350 running 24.10.0 This issue only affects untagged wired traffic destined for a VLAN. Wireless clients work flawlessly when bound to an interface.

I'm connecting several end devices so the ports are untagged. The client devices can pull DHCP addresses and ping out to other hosts but cannot do anything else. The device is otherwise configured as a dumb AP only with firewall, dnsmasq and odhcpd disabled. Network config below.

network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '2'

config device
	option name 'br-lan'
	option type 'bridge'
	option ipv6 '0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config device
	option name 'lan1'
	option macaddr 'c4:41:1e:bd:47:64'

config device
	option name 'lan2'
	option macaddr 'c4:41:1e:bd:47:64'

config device
	option name 'lan3'
	option macaddr 'c4:41:1e:bd:47:64'

config device
	option name 'lan4'
	option macaddr 'c4:41:1e:bd:47:64'

config device
	option name 'wan'
	option macaddr 'c4:41:1e:bd:47:65'

config bridge-vlan
	option device 'br-lan'
	option vlan '7'
	list ports 'lan4'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan2'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '99'
	list ports 'wan:t'

config interface 'H10'
	option proto 'static'
	option device 'br-lan.10'
	option ipaddr '10.0.10.4'
	option netmask '255.255.255.0'

config interface 'S7'
	option proto 'static'
	option device 'br-lan.7'
	option ipaddr '10.0.7.4'
	option netmask '255.255.255.0'

config interface 'NF99'
	option proto 'static'
	option device 'br-lan.99'
	option ipaddr '10.0.99.4'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'br-lan'
	option vlan '25'
	list ports 'wan:t'

config interface 'M25'
	option proto 'static'
	option device 'br-lan.25'
	option ipaddr '10.0.25.4'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'br-lan'
	option vlan '6'
	list ports 'wan:t'

config interface 'Streaming'
	option proto 'static'
	option device 'br-lan.6'
	option ipaddr '10.0.6.4'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'br-lan'
	option vlan '70'
	list ports 'lan1'
	list ports 'wan:t'

config interface 'Hidden'
	option proto 'static'
	option device 'br-lan.70'
	option ipaddr '10.0.70.4'
	option netmask '255.255.255.0'

config device
	option name 'br-lan.6'
	option type '8021q'
	option ifname 'br-lan'
	option vid '6'
	option ipv6 '0'

config device
	option name 'br-lan.7'
	option type '8021q'
	option ifname 'br-lan'
	option vid '7'
	option ipv6 '0'

config device
	option name 'br-lan.10'
	option type '8021q'
	option ifname 'br-lan'
	option vid '10'

config device
	option name 'br-lan.25'
	option type '8021q'
	option ifname 'br-lan'
	option vid '25'

config device
	option name 'br-lan.70'
	option type '8021q'
	option ifname 'br-lan'
	option vid '70'

config device
	option name 'br-lan.99'
	option type '8021q'
	option ifname 'br-lan'
	option vid '99'

config device
	option name 'eth0'

config device
	option name 'phy1-ap0'

config device
	option name 'phy1-ap1'

config device
	option name 'phy1-ap2'

config bridge-vlan
	option device 'br-lan'
	option vlan '89'
	list ports 'wan:t'

config device
	option name 'br-lan.89'
	option type '8021q'
	option ifname 'br-lan'
	option vid '89'

config interface 'B9'
	option proto 'static'
	option device 'br-lan.89'
	option ipaddr '10.0.89.4'
	option netmask '255.255.255.0'

config interface 'MGMT'
	option proto 'dhcp'
	option device 'br-lan.10'
	option peerdns '0'
	list dns '10.0.7.7'
	option auto '0'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'wan:t'

config device
	option name 'br-lan.3'
	option type '8021q'
	option ifname 'br-lan'
	option vid '3'

config interface 'Guest'
	option proto 'static'
	option device 'br-lan.3'
	option ipaddr '10.0.3.4'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'br-lan'
	option vlan '44'
	list ports 'wan:t'

config device
	option name 'br-lan.44'
	option type '8021q'
	option ifname 'br-lan'
	option vid '44'

config interface 'F4'
	option proto 'static'
	option device 'br-lan.44'
	option ipaddr '10.0.44.4'
	option netmask '255.255.255.0'

One thing is that you should not use multiple IPs on a dumbAP. Only management interface should have IP/mask/GW/DNS and the rest should be unmanaged.
Second thing is that you are mixing

The device stanza is not needed.
https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial#multiple_networks_using_vlan_tagging

Will edit and report back. This config is 100% LuCI generated FYI.