Vlan issue mt76 latest snapshot

Device: nanoHD.

Seems the last month or so snapshots are not working properly with vlan routing. Switching back to latest stable resolves this issue.

Anyone else on mt76 devices have similar issues? Is this a known issue?

There have been some firmware changes lately. I know this had an effect on DBDC. I was unaware of affects on VLAN. On cursory search I don't see any obvious VLAN entries on the mt76 issues page, but it's worth going over that and taking a look-see.

I don't use VLANs myself, but I do have many mt76 devices - several in production, and more on my test bench. Is there a simplified test case you can use to illustrate the issue that others could use to reproduce the bug? If so, feel free to post configs here and I'd be happy to test with an eye toward raising the issue on the tracker.

You can also consider checking git for what m76 change may have occurred near when you started experiencing issues.

Heres my network config, its pretty simple just a vlan for IOT network presented to bridge for 2nd ssid


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.223'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'

config device
	option type '8021q'
	option ifname 'lan'
	option vid '107'
	option name 'lan.107'

config device
	option type 'bridge'
	option name 'br-iot'
	list ports 'lan.107'

config interface 'iot'
	option proto 'static'
	option device 'br-iot'
	option ipaddr '192.168.107.223'
	option netmask '255.255.255.0'
	option gateway '192.168.107.1'

When i connect to IOT ssid, I cannot get dhcp and if i set a static ip it still cannot route out to internet. However if i am logged into AP shell, i can ping out via the ip configured:

ping -I 192.168.107.223 1.1.1.1
PING 1.1.1.1 (1.1.1.1) from 192.168.107.223: 56 data bytes
64 bytes from 1.1.1.1: seq=0 ttl=57 time=19.273 ms
64 bytes from 1.1.1.1: seq=1 ttl=57 time=11.846 ms
64 bytes from 1.1.1.1: seq=2 ttl=57 time=5.274 ms
64 bytes from 1.1.1.1: seq=3 ttl=57 time=4.267 ms
64 bytes from 1.1.1.1: seq=4 ttl=57 time=5.282 ms
--- 1.1.1.1 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 4.267/9.188/19.273 ms
root@NanoHD:~# ping -I 192.168.1.223 1.1.1.1
PING 1.1.1.1 (1.1.1.1) from 192.168.1.223: 56 data bytes
64 bytes from 1.1.1.1: seq=0 ttl=57 time=4.909 ms
64 bytes from 1.1.1.1: seq=1 ttl=57 time=4.157 ms
64 bytes from 1.1.1.1: seq=2 ttl=57 time=4.167 ms
64 bytes from 1.1.1.1: seq=3 ttl=57 time=4.955 ms
--- 1.1.1.1 ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 4.157/4.547/4.955 ms

I also notice the first few pings are quite high from the vlan interface.

Snapshot Version: r22273-bf261073dc

I figured it out. Started over fresh on snapshot build and changed vlan config to be off the bridge device (i.e br-lan.107). This is working now so i guess somewhere from stable to snapshot some DSA components have changed for mt76?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.