VLAN got IP from second ISP

Hi
So I create a second vlan for second ISP ,
I put on ISP2 router in to ip bridge , and link to My router in second VLAN
The thing is that if I use the rest of 3 LAN ports (tv appltv etc) those are getting a ip from a second ISP , like there is a dhcp going true
What to read and what to do ?
Tnx

Is this just when you boot the router? Many chips come up “leaky” before OpenWrt takes over and configures the switch.

no, both My router Ac1900 and isp router are up and runnning , I just plug appletv in Lan

I would expect that the VLAN isn't configured properly, and that you are effectively plugging your ISP cable to the switch!

could you post your /etc/config/network

@oneovidiu

You may want to edit your post (or better delete and re-post) and hide things such as username password

its ok now?

Yes, that's better. THe difference is that if you deleted the post then it disappears (after a day), but edits can be seen by clicking the pencil icon. But at least it's not visible at first glance!

    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'


config globals 'globals'
option ula_prefix 'fd7c:cf7e:3667::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.2.1'

config interface 'wan'
option ifname 'eth1.2'
option proto 'pppoe'
option username ''
option password ''
option ipv6 'auto'
option metric '10'

config interface 'wan6'
option ifname 'eth1.2'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'
option vid '2'

config switch_vlan
option device 'switch0'
option vlan '3'
option vid '3'
option ports '0 6t'

config interface 'wanb'
option proto 'dhcp'
option ifname 'eth1.3'
option metric '20'

VLAN looks OK to me! I have no other ideas.

Except maybe you could delete interface wan6. It's presumablly have nothnig to do with wanb, but it's not doing any good anyway.

Can you confirm what kind of IP you get from your second ISP?

Morinng , the ip is 109.100. . /24

Are you sure not 100.109.. ? Those are carrier grade NAT addresses, and could well be the same on multiple ISPs

It's good practice to not post your MAC address (and also global IP address if it's static) online. I suggest that you delete the post and re-post

Protocol: DHCP client
Uptime: 13h 3m 57s
MAC:
RX: 3.55 GB (2875913 Pkts.)
TX: 238.58 MB (1538726 Pkts.)
IPv4: 109.100../24

tnx :slight_smile:

1 Like

To confirm, this is how your switch looks like? (Except that LAN1 is probably plugged)

That looks like proper config.

Could you confirm that you are plugging ISP2 cable in that port (LAN4) and not another port (LAN1 maybe)? Swap them if in doubt (or unplug to see if the correct port shows diconnected in LuCI.

yes , isp2 is in lan4 , always I check the load balancing and the interfaces tab , to see if is up and going with speed test
And ofc I test iti with unplug and plug