VLAN from OpenWrt AP can't see ISP router

Hello, I am trying to set a guest network for my home. Here is a simplified version of the network diagram (the real one has more switches between the middle).

I am trying to set up an OpenWRT router as a dumb access point, doing nothing but tagging VLANs according to the SSIDs to get ready for my new ISP router (which is capable of guest networking by VLAN).

The problem is, following the guide at this page, I can get the main SSID to work, but the guest SSID won't be able to see the main router, thus not receiving the IP.

I think I've completed the guide I mentioned before, but these are the screenshots from the LuCI: https://imgur.com/a/0qlHNB7. (I can't post multiple images since I am a new user.)

Here is the /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd49:c0d3:2ad3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.11'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 4t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 4t'

config interface 'LAN_Guest'
        option proto 'none'
        option type 'bridge'
        option ifname 'eth0.2'

and /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'HT20'
        option country 'US'
        option legacy_rates '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'AP-Kitchen'
        option encryption 'psk2'
        option key '12341234'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'none'
        option ssid 'Guest'
        option network 'LAN_Guest'

I'm very new to OpenWRT, so please suggest me should I have made any errors. Thank you in advance!
-- srakrn

It's correct, but use lower case characters for the interface name and avoid if possible the underscore. guest is totally fine as a name.

1 Like