Vlan DSA usage on device with just one eth port

I've read DSA on one eth port
I get 3 VLANs to port - vlan 1 ist management and is untagged and 10,22 who are tagged for IOT and GUESTS. DHCP and routing is done on dedicated router

and i got these two configs that both work, but i want to know why and which is "better">

config device
	option name 'br-lan10'
	option type 'bridge'
	option bridge_empty '1'
	list ports 'eth0.10'

config interface 'lan10'
	option proto 'none'
	option device 'br-lan10'

and

config interface 'lan22'
	option proto 'none'
	option device 'br-lan.22'

config device
	option name 'br-lan22'
	option type 'bridge'
	option vlan '22'
	list ports 'eth0'

config bridge-vlan
	option device 'br-lan22'
	option vlan '22'
	list ports 'eth0:t'