Hello forum,
Using the WRT1900AC, openwrt version 23.05.
Trying to setup port 1 to send out Vlan 5 management, 10 work and 20 guest.
Looked at 10 videos online feels like the wild west out there - no joy -
Also, read the mini DSA, I believe I have get the idea of what is going on:
Basically create an create a bridge, then an interface static IP, assign the DHCP range and the firewall output zone, then tight up the bridge with the interface and tag the port and vlans together. (using Luci)
But, doing that so far not been able to make work, anyone who can help me that will be much appreciated.
Happy to help.
Let’s start by reviewing the config.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
So we are going to you SSH, instead of Luci. my plan is to reset the router and start fresh, is just simpler that way. Going to do that in the AM since is getting pretty late now - sorry to put you off, been batling this since yesterday.
Wondering if you have a sample file something to work from (I mean since you are familiar configuring via SSH) ?
It would be much easier to send us the output requested, as not everyone has the same device, so we'd need to see how it is configured currently.
You can certainly search the forums for other threads involving VLANs with DSA -- there are plenty. But I'm guessing you've done that and are still having a bit of trouble (it can take a bit to wrap your head around how DSA works)... so, aside from what @trendy said (which is a large part of the reason I asked for your config), the other reason is that we can help you achieve the exact config you want instead of just reading 'generic' solutions or customized ones for other people.
Preformatted textEnd up using a better router that I had, here is the information you requested.
root@OpenWrt:~# ubus call system board
{
"kernel": "5.15.134",
"hostname": "OpenWrt",
"system": "MediaTek MT7621 ver:1 eco:3",
"model": "Linksys E7350",
"board_name": "linksys,e7350",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.0",
"revision": "r23497-6637af95aa",
"target": "ramips/mt7621",
"description": "OpenWrt 23.05.0 r23497-6637af95aa"
}
}
root@OpenWrt:~# cat /etc/config/network
Press "Enter" and paste the output of the last command.
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd96:2ec5:d8be::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config device
option name 'lan1'
option macaddr '80:69:1a:1a:6c:XX'
config device
option name 'lan2'
option macaddr '80:69:1a:1a:6c:XX'
config device
option name 'lan3'
option macaddr '80:69:1a:1a:6c:XX'
config device
option name 'lan4'
option macaddr '80:69:1a:1a:6c:XX'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'wan'
option macaddr '80:69:1a:1a:6c:XX'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
Please let me know if I need to omit the MAc addresses, from the code, also using a fresh router, once I grasp the concept should be pretty straight forward.
config bridge-vlan
option device 'br-lan'
option vlan '5'
list ports 'lan1:t'
config bridge-vlan
option device 'br-lan'
option vlan '10'
list ports 'lan1:t'
config bridge-vlan
option device 'br-lan'
option vlan '20'
list ports 'lan1:t'
config interface 'mgmt'
option device 'br-lan.5'
option proto 'static'
option ipaddr '192.168.5.1'
option netmask '255.255.255.0'
config interface 'work'
option device 'br-lan.10'
option proto 'static'
option ipaddr '192.168.10.1'
option netmask '255.255.255.0'
config interface 'guest'
option device 'br-lan.20'
option proto 'static'
option ipaddr '192.168.20.1'
option netmask '255.255.255.0'
Getting this error
-ash: -ash:: not found
According to what I have found online looks like I need to do a system upgrade, but not sure if that is the case - Any ideas?
Using the firmware selector I was able to upgrade to another version a bit higher (OpenWrt 23.05.2)
That worked for another user with the same problem I am getting still same error, will keep reading about it until I can figure what the issue is.
This is the error,
-ash:: not found
What command are you entering that elicits that response?
I don’t really seeing how ash comes into play here.
This command:
config bridge-vlan
Did you read this already?
This is not a command to be entered on the command line interface... it is part of the config file itself.
The config files can be edited in a few ways, but on the command line you would use UCI syntax. I personally often directly edit the config files using the vi text editor that is included by default in OpenWrt.
Oh the WRT1900AC now has DSA under 23.05?
For a couple releases already, all wrt1200ac/wrt1900ac/wrt1900acs/wrt3200acm/wrt32x mvebu devices.
I see, wondering if I should create the file first and then trasfer to the router or if I should edit in the router itself? Also, doing the command ls to list the contents does not give me anything, then I tried ll and got:
root@OpenWrt:~# ll
drwxr-xr-x 2 root root 3 Nov 14 13:38 ./
drwxr-xr-x 1 root root 224 Jan 1 1970 ../
I learning how to navigate via SSH inside the router, once I locate the file I need to edit, it should be straight forward, but so far I have not been lucky in getting the information to know which editor OpenWRT uses, if anyone can share the commands list that will be great help.