VLAN does not work after update to 23.05

Hey everyone!

I am running a D-Link DIR-2660 A1 Router with OpenWRT I decited to update to 23.05 since it is on stable now.

I left the configuration as it was before and everything works fine except the VLAN.
One Port needs to transport all 3 VLANs to another VLAN Switch. This Port is configured with a T on all the VLANs.
I have a VLAN DSA syntax
Since I didnt changed anything I have no clue how to find out why it is not working.
If I switch all of the Ts to Not Member except one I left on U I got connection to the devices begind the VLAN Switch, so Network is still ok.

I hope you can help me how to do some diagnostics
Here is my Network Config


cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fdfc:ddb5:0bba::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option device 'br-lan.3'
	option ipaddr '192.XXX.0.1'
	list dns '192.XXX.0.1'
	list ip6class 'wan6'
	option ip6ifaceid 'eui64'
	option ip6assign '64'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option broadcast '1'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '8.8.8.8'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option peerdns '0'
	list dns '2606:4700:4700::1111'

config device
	option name 'lan1'

config device
	option name 'wan'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan1:t*'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'lan1:t'

config interface 'private'
	option proto 'static'
	option device 'br-lan.1'
	option ipaddr '10.XXX.XXX.1'
	option netmask '255.255.255.0'
	option broadcast '10.XXX.XXX.255'
	option gateway '100.83.0.1'
	list dns '10.XXX.XXX.1'
	list ip6class 'wan6'
	option ip6ifaceid 'eui64'
	option ip6assign '64'

config interface 'server'
	option proto 'static'
	option device 'br-lan.4'
	option ipaddr '10.XX.XX.1'
	option netmask '255.255.255.0'
	list ip6class 'wan6'
	option ip6ifaceid 'eui64'
	option ip6assign '64'


Thank you so much!

Welcome to the community!

What version of OpenWrt did you upgrade from?

2 Likes

Can you elaborate on what is and is not working, specifically...

Is the trunk not working? Or one or more specific ports? Which network(s) are working and which aren't?

3 Likes

Hey, thank you so much for your fast reply.
So previously I hat 22.03 installed which worked without any problem.

I think the trunk is not working. All Networks and interfaces are working.
I will try to use another port for that configuration but that will just be a test.
Any ideas how to test the trunk?

What is the trunk connected to? Typically it would be a VLAN aware switch or AP.

When you say that the trunk isn't working -- does that mean that there is no connectivity? Have you checked to see if devices get DHCP issued IP addresses on each network (i.e. via a managed switch with access ports defined, or an SSID per network for an AP)?

Do the other ports work

1 Like

Yes, all the other ports are working on that Ports (U) are devices connected directly.

The trunk is connected to a Netgead managed switch.
I have no connection to the switch or any device behind the switch.
No Device behind that swtich is able to get a DHCP issued IP.

Heres a Screenshot of the Netgear

What is the port that is being used as the uplink from the switch (to the router)?

Are all of the VLANs tagged on that port?
Can you setup 3 ports such that there is one port for each VLAN set tp untagged + PVID (and no tagged VLANs on those ports)? Then, plug a computer into each of the ports, in turn, and see if it can get a DHCP lease on the correct network.

I do see a few minor things I'd recommend fixing, but it is important to first understand the full scope of the issue.

1 Like

Hey,
thank you very much for your help!
So I reconfigured the managed switch from scratch and although I did nothing different it is working now - whatever :smiley:
Thank you!!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.