VLAN configuration on Access Points Netgear EX6100V2 & EX6150V2

Folks

I am trying to use the following access points:

  1. Netgear EX 6100 v2
  2. Netgear EX 6150 v2

Both appear to be based on identical chips: IPQ40XX.

Both, in their default config, have nearly same network file as in /etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd94:aec3:80f4::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

I have tried many ways of assigning vlans using devices tab of network and using 802.11q but it has not worked for me. Then I discovered that the default config file has no switch statement hooking it to CPU and there is no declarative for vlan enabled, like here in my another access point:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option description 'lan'
        option ports '6t 3 2 1 0 4t'

config switch_vlan
        option device 'switch0'
        option vlan '6'
        option description 'iot'
        option ports '6t 4t'


I have two vlans. The default 1 and another vlan 6 for iot / guest. And I wanted to set the same in these two AP's as well.

Is there any guidance or should I just assume these EX6100v2 and EX6150v2 need to be connected to untagged ports only.

Much appreciate.

Anil

All I can say is VLANs are iffy on IPQ40xx with swconfig (DSA PR is pending for master). Tried it once and failed. I think both VLAN 1 and 2 are special but it's been a while since I tried.

Pardon me if my question is stupid.

I set up 1 as LAN and 6 chosen randomly for IOT/GUESTS
My consumer grade POE switches allow only a few vlans and not 4096 like commercial ones (I think).

You say 1 and 2 might be special with these. Is it worth investigating if I change my lan to say 7 and IOT to 8 and wan to 9. Or you think its not worthwhile..

LMK.

anil

Certainly worth a shot I'd say.

1 Like

Anil I see you are eager to get an answer, but are the multiple threads necessary?

1 Like

My bad, I hadn't considered that this will create multiple threads. I am sorry, i don't mean to flood and neither is my need that critical as its used in home. I'll be more careful next time..

Will try this weekend. I noticed that on my Netgear smart switch they have two vlans predefined and not removable. One is vlan 1 and named as default and the second is vlan 2 and named as auto VOIP.

Thanks.

@agarg You can flag the other topic for closure/deletion to the mods.

I am waiting to find out the syntax for the openwrt rev 22 switch in the config/network file. I have only one port but I saw it listed 0 through 6.

There's little reason to assume it would be any different for IPQ40xx. It's still swconfig based. Even if it were DSA it would still make no sense to split closely intertwined questions into separate topics.

Nothing holding you from testing the water with 22.03 RC5 e.g. :slightly_smiling_face:. All my stuff at home is on 22.03 ever since it got branched (well before any RC was published).

I just discovered an interesting command and using that I got whole bunch of data and small part of that is

root@OpenWrt:/etc/config# swconfig dev switch0 show

Global attributes:
        enable_vlan: 1
        enable_mirror_rx: 0
        enable_mirror_tx: 0
        mirror_monitor_port: 0
        mirror_source_port: 0
        linkdown: ???
Port 0:
        mib: Port 0 MIB counters
RxBroad     : 3
......
......
......
VLAN 1:
        vid: 1
        ports: 0t 1 2 3 4 
VLAN 2:
        vid: 2
        ports: 0t 5 

Using this, I tried to guess and created few lines in the network file in config directory:

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 5'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '6'
        option ports '0t'

When I rebooted, I do see now the missing switch entry automagically appear. But it says

Switch switch0 has an unknown topology - the VLAN settings might not be accurate.

I am also attaching a screenshot. Any suggestions?

I like that word!

What happens if you invert port 1 (all vlans) with cpu eth0 (all vlans)

Comparing your screenshot to my system my: my cpu eth0 is tagged

Bill

Does your device also say, unknown topology?
Will you be kind enough to share your /etc/config/network ? and then I can try to figure it out. I have two vlans: IOT + Guests and second vlan is just lan. It appears that on this device we can not use vlan 1 and vlan 2 and totally OK with it. I want to be certain before I go ahead and try to change the existing vlans whic use vlan "1" and vlan "2" and vlan '6'

Thanks
Anil

I don't how to invert. And I ask only because my device says device has unknown topology.
If I don't immediately understand, I am sorry but I will keep trying.

Thanks.

Well you're telling swconfig there's ports that actually aren't there. That's why I suppose it's saying 'unknown topology'.

Ask yourself: how many physical RJ-45 ports are exposed? That's the amount of ports (plus the CPU, usually) that you will see in swconfig.

What you say is totally right. When I entered

swconfig dev switch0 show

it gave me the output:

VLAN 1:
        vid: 1
        ports: 0t 1 2 3 4 
VLAN 2:
        vid: 2
        ports: 0t 5 

So I thought these are hidden ports.

I will try just with zero and 1 and see what happens. I am getting more courage now.

Thanks again.
Anil

I tried just defining switch and enabled vlan but no vlans were specified. Even then it came back up on Luci with so many ports. So, even though it has only one Phy ethernet port, internally it has many ports. My only hope is for someone to share their switch on EX6150v2 which I can then adapt to my vlan.

1 Like

My VLAN config on eth0 for EX6150v2 seem to have worked now. The solution that worked for me is described in VLAN Tagging on Linksys EX6150v2 - #3 by Jonny007-MKD

Luci still shows "Switch switch0 has an unknown topology - the VLAN settings might not be accurate." and also the VLAN ID is marked red saying that it expects a value between 0 and 15 when I specified VLAN ID 20, but it still seems to work just fine.

In my case I added to following blocks to /etc/config/network

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 4t'

config switch_vlan
        option device 'switch0'
        option vlan '20'
        option vid '20'
        option ports '0t 4t'

config interface 'vlan20'
        option proto 'none'
        option device 'br-vlan20'

config device
        option name 'br-vlan20'
        option type 'bridge'
        list ports 'eth0.20'