VLAN config on Linksys EA8500

Hi,

I've got a Linksys EA8500 with me, running KONG IPQ806X builds based on OpenWRT 19.07.

My university dorm room has ethernet wall jacks, and plugging my router in to it gives me a private IP (172.17.61.115/16) according to OpenWRT GUI.

The setup I want is:

WAN port (ethernet cable from wall jack for router to get internet access)

LAN port 1 (act as a switch for the wall jack, so let the dorm router hand out IPs through DHCP)

LAN port 2 (give me a 192.168.1.x IP from the EA8500 itself)
LAN port 3 (same as above)
LAN port 4 (same as above)

So essentially all I want is LAN port 1 to act like another ethernet wall jack in my room.

The dorm IT guys have allowed my PS4 through their very strict firewall, and since there's only one ethernet wall jack in the room, I don't want the PS4 to occupy that, but I also want to use my own router and not the crappy dorm WiFi.

If I just plug the PS4 in to the OpenWRT router without doing anything, I'll get a double NAT situation and that affects some games and voice chat.

This is the default config on the router:

If you guys could point me in the right direction and let me know how to go about this, I'd really appreciate it.

I do have some experience with configuring OpenWRT routers through CLI, so if that is required, I can give it a shot.

Thanks

This would be a one minute job... if I had your current network config file :wink:

2 Likes

I'd be very thankful if you could give it a quick look and let me know what needs to be changed:

This is the original file:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd94:bdaf:c44a::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option macaddr 'C0:56:27:09:00:27'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr 'C0:56:27:09:00:27'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option macaddr 'C0:56:27:09:00:27'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'C0:56:27:09:00:27'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 1 2 3 4'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'
	option vid '2'

1 Like

No, before starting with the configuration, may I ask why do you have changed the LAN's MAC to the same address as the WAN?

1 Like
  • LAN4 ID 1 - change to off
  • LAN4 ID 2 - change to untagged
  • Save and apply

This will make the LAN4 port on same physical network as the wall jack. Be mindful, sometimes the ports are numbered in reverse from the labeling on the device.

1 Like

An this is how I think it should look:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd94:bdaf:c44a::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option macaddr 'C0:56:27:09:00:27'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr 'C0:56:27:09:00:27'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option macaddr 'C0:56:27:09:00:27'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'C0:56:27:09:00:27'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 1 5'
	option vid '2'

Sometimes, switch port numbers do not match the port numbers on the router's case; try to plug the PS4 on the first or the last port.

2 Likes

Was having some troubles with MAC spoofing and was experimenting with the config file.

Thank you so very much!
It worked like a charm.

Updated the network config file, restarted the router and everything works perfectly.

LAN1 is connected to the PS4 and I tested it by trying to join a game, played for a minute or two to see if anything was lagging or acting weird, but all is well.

Remaining LAN ports are working as they should, giving me 192.168.1.x IPs.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.