Vlan config dont receive dhcp in wifi - OpenWrt 18.06

Hey guys,

I need to configure my home network to segregate my wifis.

Wifi IOT_Network should be in Vlan 100 (10.0.100.0/24)

Others Should be in Lan (192.168.1.0/24)

This is a drawing of my current topology.

i tried configure, but no sucess

Iot wifi dont receive dhcp from Vlan 100.

this is my configs:

Network:

config device
	option name 'eth0'
	option macaddr 'redacted'

config device
	option name 'eth1'

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config switch 'switch0'
	option name 'switch0'

config switch 'switch1'
	option name 'switch1'
	option enable_vlan '1'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option multicast_querier '0'
	option igmp_snooping '0'
	option macaddr 'redacted'
	option mtu '1500'
	option ifname 'eth0 eth1'
	option ipaddr '192.168.1.5'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

config interface 'eth1'
	option ifname 'eth1'
	option keepup '1'

config interface 'eth0'
	option ifname 'eth0'
	option keepup '1'

config interface 'miot'
	option ifname 'wl13'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.32.1'
	option netmask '255.255.255.0'

config interface 'guest'
	option ifname ' '
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.0.15.1'
	option netmask '255.255.255.0'

config switch_vlan
	option device 'switch1'
	option vlan '1'
	option vid '1'
	option ports '1 2 3 6'

config switch_vlan
	option device 'switch1'
	option vlan '2'
	option vid '2'
	option ports '4 5'

config switch_vlan                        
        option device 'switch1'           
        option vlan '100'                   
        option vid '100'                    
        option ports '4t 5t' 

config device
	option type 'bridge'
	option name 'BR-VLAN100'
	list ports 'eth0.100'

config interface 'VLAN100'
	option proto 'dhcp'
	option device 'BR-VLAN100'

Wireless

config wifi-device 'wifi0'
	option type 'qcawificfg80211'
	option macaddr 'redacted'
	option hwmode '11axg'
	option htmode 'HT40'
	option country 'CN'
	option disabled '0'
	option txbf '3'
	option ax '1'
	option txpwr 'max'
	option channel '0'
	option autoch '2'
	option bw '0'

config wifi-iface                                                                          
        option device 'wifi0'                                                              
        option network 'VLAN100'                                                               
        option mode 'ap'                                                                                                                                                            
        option disabled '0'                                                                
        option bsd '0'                                                                     
        option encryption 'none'                                                           
        option ssid 'IOT_Network'                                                             
        option hidden '0'                                                                  
        option macfilter 'disabled' 

18.06 is long since EOL and unsupported. Most people won't even remember the correct syntax to configure those devices (I certainly don't), and it's just as well given that 18.06 has many known serious security vulnerabilities and shouldn't be used anymore.

Please upgrade to a currently supported version -- 23.05 or 24.10.

Thanks for the reply,

This openWrt is installed on an unsupported official device (Xiaomi AX3000), but it works fine kkkk. I'm using it as a Wi-Fi dumb and switch.

I have another OpenWrt with v23, but I don't want to add more nodes to my network. In some videos, this version (18.06) doesn't use DSA for Vlans.

With DSA, I configured it successfully, but v18 was not successful.

So where did the firmware come from? AX devices weren't available at the time that 18.06 was current, so this must not be from the official OpenWrt project.

DSA is not supported in any official OpenWrt version prior to 21.02. OpenWrt 18.06 used swconfig for all devices.

DSA syntax won't work with 18.06 (at least from the official project).

Chineses have no limits kkkkk

I tried using swconfig, but maybe I didn't configure it correctly

You will need to ask the people who provided and maintain that firmware. It is not from the OpenWrt project, so it cannot be supported here.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.