vLAN at OpenWrt 21 on x86/64 with single port and Archer C7 V2

I have the following network at which the the role of Router is done by OpenWRT 21 x86/64 as a virtual machine inside of Proxmox and my Archer C7 V2 is serving as a dump Access point.

These days i wanted to make a Guest wlan and make it in different subnet but the problem is at my NUC 10 i have only one ethernet port and at the LUCI i dont have SWITCH menu so i can assign VLANS.


Of-course from Network -> Interfaces -> Devices (tab) i can create a VLANs (820.1q) but how i can assign which VLAN IDs will be tagged/untagged as i dont have the menu as i have in my Archer C7?


eth0 (untagged) vs eth0.1, eth0.42, eth0.73, ...

Obviously there can only be one untagged VLAN, for more you'll have ti rely on your managed switch to do the untagging for you on dedicated (switch-) ports.

In a VM installation you would have to use the hypervisor to configure VLANs on the physical port, then couple them to the OpenWrt instance, typically as separate virtual ports which are layer 2 bridged to their VLAN on the physical port. That is outside the scope of this forum.

When OpenWrt is running on the bare metal, which is generally recommended for a dedicated main router, then it can directly create VLANs on a port with the notation 'eth0.N' where N is the VLAN tag you want to apply.

The switch in the Archer C7 can be readily configured to direct the different VLANs on the trunk cable to different switch ports and/or separate lan and guest wifi AP instances in the C7.


Sound logic, already found the option at Proxmox and now trying to set it up.

At Proxmox you enter the VLAN tag


and after it apear as new device

But still cannot connect to my Guest wlan from dump access point :confused:

At dump access point (archer c7) this is how i set up

Try changing VLAN 1 to also be tagged on the trunk cable. Mixing tagged and untagged on the same cable doesn't always work.

While setting this up, you may want to set up a local "admin" network on the C7 with a DHCP server and a wifi AP so you still have a way to log into the C7 if the Ethernet is not working.

I thing all the problem is at my Proxmox, there is something that need to set up that i dont know yet :slight_smile:

So after a long trial and errors i finally found the solution and the problem which didn't allow me achieve it :slight_smile:

At Proxmox the vLan functionality is working fine
To be honest much easier than i though because the only what you have to do is to add a network device and put the vLan ID there, once you did it it immediately appear at Network -> Interfaces -> Devices (Tab)


of course the precondition is to have VLAN Aware enabled at your network device of Node

All the problem was at my Archer C7 where the vLans by DSA didn't worked for me but worked only with traditional way via Switch menu

and the biggest problem (that was the main reason why i could not achieve my goal all this time) was that i had to create a Bridge device, put my VLAN (802.1q) there and at Interfaces select it as device (not directly the VLAN as device, but through Bridge)


Hope it will help in the future anyone :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.