Vlan 10 tagging

Hi,

I have an Archer TP Link MR200 from Orange (Belgium). It runs Openwrt 22.03.2.

I want to change ISP from Orange4G connection to fibre optic. Up/down speeds are 100/50mbs for €35 a month. The fibre company wrote this requirement for the routers:

ATTENTION
please make sure that your hardware has a Gigabit Ethernet port, that it can build up a PPP-session and that it supports vlan 10 tagging.

Can OpenWrt do this, and how? Because I cannot see how to do it, yet.

TIA!
S

Yes, OpenWrt can do this, definitively.

4 Likes

There are different versions of the MR200 but I don't think any of them support gigabit Ethernet. With a 100 Mb port you will be limited to 94 Mb net throughput.

ppp is a standard software feature and VLANs work on almost every model. The MT7620 and MT7628 chips found in the various MR200 versions really aren't enough CPU power for triple digit speeds though.

4 Likes

If they will auto negotiate down to 100MBs then all is well.

They sell 100 down/50up for €35.
94MBs is fine, because right now my down link is between 10 and 20 MBs.

Where can I configure vlan tagging?

What is the output of uci export network run from ssh?

Hi,

It's :

# uci export network
package network

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fd82:FFFF:FFF1::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'br-lan'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '18:d6:FF:FF:FF:FF'

config interface 'wan'
	option proto 'dhcp'
	option device 'usb0'

config device 'wan_dev'
	option name 'usb0'
	option macaddr '18:d6:FF:FF:FF:FF'

config interface 'wan6'
	option proto 'dhcpv6'
	option device 'usb0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 6t'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

My ISP requires VLAN 10 on the PPPoE interface as well, works just fine.

config device
	option type '8021q'
	option ifname 'p8'
	option vid '10'
	option name 'fiber'

[...]

config interface 'wan'
	option proto 'pppoe'
	option username '***********'
	option password '***********'
	option ipv6 '1'
	option device 'fiber'
1 Like

Thanks. I can add ppp + vlan10 to my WAN NiC and see if it works with the fibre when I order it.

If of does not work for whatever reason, is there a small wifi router running openwrt that runs well with fibre?

I will never afford 1GBs here so my requirements are low ( Amazon Firestick 4K + 2 iphones).

It's pure software, the settings I shared is how you do it with DSA. You should not have any issues.

The reason why your ISP talks about 'make sure your hardware supports it' is because I can imagine multiple vendors not considering VLAN tagging on the WAN interface a consumer product feature, just like VLANs altogether.

2 Likes