Virtualization on APU- Hardware fails

I'm using APU - Hardware (APU3C4 - headless) for OpenWRT, and try (by the book ) - to get a VM running, using kmod-kvm-amd .
Now whether I'm installing a new Debian as exactly describe there, or starting an imported machine, the process fails - without me seeing anything in the logs.

  • Running the imported machine shows me the bootloader- menu, but as soon as the kernel loads the screen is black (apparently no restart - but no DHCP- requests from it either)
  • Running the installation, I see the VM "power-cycling" every 15 seconds or so

As I have left standard naming conventions, I do have a "br-lan". As I'm out of eyes and logs here, I'd welcome any hint towards a solution...
Thanks in advance,
Chris

I wouldn't really recommend using plain qemu for newbies.
APIs tend to change and old configs and methods may not work correctly with newer versions of software.
In addition, each distro has its own specifics, e.g. authorization, authentication, network management back-ends, mandatory access controls, etc.
Therefore, setting up a VM is preferable with GNOME Boxes or Virt-Manager, which invoke libvirt with mostly optimized and up-to-date configuration.
Then you just need to change the network adapter model to virtio and the rest should work fine.

Thanks vgaetera,
but the import is exactly what I actually tried first (see first bullet point). The machine was running fine in my environment, I have imported the disk image, started it and - blank screen after kernel load.

Post your configuration:

virsh list --all
virsh dumpxml VM_NAME

The VM was created on another machine, hence I do not see the relevance of the virsh- commands, nor the former config of the VMs? It's Centos8-Stream, used to run with 768MB RAM and a virtio- disk.
This is the command I try to start the VMs with on the APU:
qemu-system-x86_64 -enable-kvm -cpu host -smp 2 -m 2G
-drive file=/mnt/sda1/qemu/centos8/disk01.qcow2,if=virtio
-device virtio-net-pci,mac=00:0D:B7:5C:51:F0,netdev=br0
-netdev bridge,br=br-lan,id=br0
-nographic

And when daemonizing, instead of "-nographic":
-qmp tcp:127.0.0.1:4444,server,nowait
-daemonize &> /var/log/qemu.log

As I mentioned above, using plain qemu is not wise, unless you know exactly which parameters are fully compatible and optimal for your current host system, so I advise you to re-create the VM with libvirt.

Sorry, I think there's a misunderstanding:

  • I want to virtualize a guest on openWRT
  • the qemu - part is to start the system on openWRT (see here )
  • openWRT is running on an APU - there's no virsh / libvirt to run guests with
  • I did create the Machine on a full-fledged Linux- System (with virt-manager)
  • I did also try to create a machine as per documentation (see " Installing Debian as guest OS")

My issue is, that the machine is not booting on openWRT...

1 Like

Thanks, I got it now.
Unfortunately, I'm going to disappoint you.
Let's be honest, OpenWrt is not a general-purpose Linux distribution.
And virtualization functionality is somewhere on the outskirts of development focus.
You won't be able to achieve the same level of stability, reliability and support as CentOS or Debian when using OpenWrt as a virtualization server.
If you really need virtualization and the hardware is powerful enough, it's best to install at least a general-purpose Linux distribution if not a specialized one like Proxmox.

1 Like

I have a couple of APU1c initialized with Debian and I tried once to use kvm virtualization and it fails. Did not equire more. These are old models of APUs.

1 Like

Thank you, I kind of guessed so. I might hope for docker/podman to make it into the stable branch then I suppose... :slight_smile:

1 Like

docker-ce is available in 19.07 for the traget x86_64 on OpenWrt if I'm not totally wrong.

Hi juppin, unfortunately it doesn't seem to be in 19.07, neither can I find it in the dev- snapshot (which I don't want to use).