VirtualBox wan interface performance

Hello,

I am currently running a fresh install following the direction in the wiki. All is well from a connectivity and routing stand point. I have a cable modem that is serving a DHCP address.

I am configured with a pair of bridged physical adapters in VirtualBox. They are Intel 1000 MT.

OpenWrt adapters are configured as:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd04:aef2:107b::/48'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
	option hostname 'Arris'
	option type 'bridge'

config interface 'mng'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ifname 'eth0'
	option ipaddr '192.168.56.2'

config interface 'lan'
	option ifname 'eth2'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.11'
	option type 'bridge'

If I connect directly to the cable modem in the host (Windows 10) with the same nic I am seeing close to gigabit speeds.

Turning on all windows options on the nic and letting the VM control it is when the speeds drop. I will seeing 350Mbit from client and when running a speed test directly from the router using speedtest-cli.

I have spent time trying other nic options and drivers. I have also changed just about every system option in VirtualBox and am seeing no change in throughput.

Any help would be greatly appreciated.

Thank you,
Rick