Virtualbox Guest Additions

I followed the instructions on the official website using vdi images. But when I click the insert Guest Additions in Virtualbox menu, nothing happened and no cdrom in /media. How can I do with this? I want to use the Guest additions to using the shared folders.
Many thanks!

Please explain how the Shared Folder feature would work for you with a router Distribution?

Perhaps I can understand what you're trying to do and asssit.

I just want to add a shared folder through virtualbox and then mount the folder, I considered it as a disk, to the system. Or, may be there are other method to add a disk to the virtualbox guest system?
Many thanks in advance!

If you want to add a disk, you just create and attach it in the OpenWrt control panel like other VMs; but I understand that you want to use the OpenWrt VM like a folder accessible from the host.

You will need to install the packages for CD-ROM access, you should then be able to browse to the folder and run sh ./


An alternative is to setup FTP or SAMBA.

Hope this helps.

You might also need to install block-mount and the appropriate USB and file-system kernel modules on the OpenWRT guest. At least for the "embedded" devices, those are not present by default and need to be added either to the build or installed as packages.

I guess I have to do:
opkg install kmod-fs-isofs
for Kernel module for ISO9660 filesystem support

But I got
Collected errors:

  • pkg_run_script: package "kmod-lib-zlib-inflate" postinst script returned status 255.
  • opkg_configure: kmod-lib-zlib-inflate.postinst returned 255.

A search found this thread:

Any idea?

  • What version of OpenWrt did you flash?
  • Were you told that it failed to find a module?
  • Were you installing kmod-fs-brtfs??? (I saw the thread you posted, but I'm not sure why you linked it)

Please provide the full error message in the future.


Fixed/workarounded with;a=commitdiff;h=efb6ca189641aec64ba94f0d6d4e008fb2c1668b

Fix will be in 17.01.5; in the mean time, it can be applied manually in /lib/ .

I also tried using samba. But again I encounter code 255

Here is the command and output in terminal:

 opkg install kmod-fs-cifs
Package kmod-fs-cifs (4.4.61-1) installed in root is up to date.
Configuring kmod-lib-zlib-inflate.
failed to find a module named zlib_inflate
Collected errors:
 * pkg_run_script: package "kmod-lib-zlib-inflate" postinst script returned status 255.
 * opkg_configure: kmod-lib-zlib-inflate.postinst returned 255.

I just followed the instruction using the vdi image from the official website:
LEDE Reboot 17.01.1 r3316-7eb58cf109

Sorry for the confusion about the link, I am just wondering what the code 255 means and it has the same error information for package "kmod-fs-cifs", "kmod-fs-isofs", "kmod-fs-brtfs",

Is there a reason you're attempting to use an old version of LEDE?

The current stable release as of this post is: 17.01.4.

Try using --force-depends with the opkg command.

Thanks for those ideas, I will update to the latest version first.

Tried 17.01.4, failed again. But this time I first passed kmod-fs-cifs, but then after I install block-mount, then "kmod-fs-isofs", "kmod-fs-brtfs" failed. Same error information.

Not sure why you're trying to install brtfs only shows as dependencies

  • kmod-lib-zlib-inflate
  • kmod-nls-base

Seeing the complete output and error messages may help someone understand what is happening. The code-block button </> can be used to format the output in a readable way.

Yes, you are right. I solved this by
rm /usr/lib/opkg/info/kmod-lib-zlib-inflate.postinst

Thanks all guys! But I am considering on giving up on virtual box images.