Virtual Machine, OpenWrt, Slow PPPoE Performance


I would like to get some help with QNAP Virtual Machine & OpenWRT & Slow PPPoE performance.

I have installed the luci-app-statistics and can see that all my 4 CPU cores are not fully utilised and as a result, I am not able to achieve full download speed of 910Mbps. Currently now only getting download speed of 215Mbps!

Is there a way I can find out what is causing the bottleneck in my setup please?

Is there way I can increase the performance of the CPU load balancing by enabling CPU Governor Performance mode? And if so, how do I do this please?


My crystal ball fails to detect your setup.
Please provide a complete setup description.


Hah, sorry posted in a rush!

Virtual machine hosted on a QNAP Server with LAN and WAN both configured as VirtI0. 4 CPU cores allocated to the Virtual Machine with 16GB of RAM (overkill I know).

WAN in OpenWRT configured using PPPoE connection.

Please let me know if you require any further details?


  • Do you mean you attached LAN and WAN to the same [virtual] PHY or bridge?
  • So virtual eth0 and eth1 are on the same network?

To what/where?

Bridged network for LAN and WAN, each using their own Adapters and available to see each other on the same network - please see following photo:

BT Openreach Modem ONT connected directly using Ethernet to WAN port on Server Switch.

1 Like

Did you try enabling packet steering?


Tried this, no success.

Also tried software and hardware offloading, no success.

My CPU cores are not being properly utilised.

Does anyone know how to check the CPU setting e.g. ‘performance’ in a virtualised environment please ?


I know how to see/check on ESXi and VirtualBox, KVM/QEMU...since you're starring at it.

Would you be able to explain what you meant please?

I’m currently using Qnap Virtualization Station to run my Virtual Machine with OpenWRT installed…

Yes, you noted that.


Unless I misunderstood you asked:


I assumed you meant in QNAP Host, so I provided their support channel. It's quite simple on other VM hosts - as it has to be configured when setting up the VM.

If you mean the OpenWrt VM, see:

You set using the sysctrl comman or the file /etc/sysctrl.conf

I'm not sure this is the issue, though - I had speed issues in an VM too: [Solved] X86_64 regular traffic slow but Wireguard wow

Thanks for your help.

Yep, struggling to find where or which path to view what the CPU mode is on a Qnap VM! Will see what their support says…

It appears that Qnap supports containerization with LXC/LXD. OpenWRT works brilliantly as a container. This just about completely eliminates the paravirtualization overhead, which can be significant for interrupt-driven workloads.

Shall I look at ways to install OpenWRT in a Docker Container then, is that what you mean? Thanks.

Mmm, no, Docker's more for individual applications. LXC is the core linux containerization project (Docker was originally based on it) and supports a whole operating system, sharing only the kernel with the host environment. Look up Qnap's support for LXC. Looks like they're moving to supporting LXD exclusively, it's a more systematized variant on LXC with a lot more automated support for managing container resources.

I’m using Qnap’s Virtualization Station 3. I thought I was running OpenWRT correctly in Qnap? I installed it using Qnap’s VM Installer and then upgraded the OpenWRT firmware using Luci Web UI…

I don't have a Qnap so at this point I'd just be googling same as you can. I just thought I'd introduce the topic, since virtualization is often unnecessary and even unadvisable when containers can do the job with essentially no emulation overhead, so I googled Qnap LXC and saw that they do seem to have some support for it. That's as far as I took it. Feel free to follow up or discard the suggestion.

No problems, as far as I understood, Qnap currently supports running OpenWRT using Virtualization Station.
I believe the non supported aspect is experienced in Container Station running LXC, thanks.