Virgin Cable + BT Hub5A [Solved]

HI all, newbie be here. Sorry if this is a dumb question.

I have Virgin media UK has my ISP with a cable SuperHub2 AC router and I am having problems accessing the internet with the BT Hub5 with OpenWRT. I put the Virgin router in to modem mode and on the BT Hub setup a new wan interface with a static IP and DNS on the wan port of the BT Hub, firewall profile to wan but I cannot get out to the web. Am I doing something wrong, please help.

Details on modem mode
Super Hub 2ac
Enabling modem mode allows you to connect your own WiFi kit to the new Super Hub, effectively turning the Super Hub into a stand alone DOCSIS3 cable modem


Just found this on the BT Hub Page. Would this be correct to solve the issue.

Example board.json tweak

:black_medium_small_square: you want to use the WAN port, not DSL, for your uplink
:black_medium_small_square: you're using a LuCI newer than commit 3ea9c85e (mid-Aug 2016) meaning you see LAN 1 – LAN 4; either you're annoyed that you can't see port 5, or you're annoyed at the UI not matching the labelled port
:black_medium_small_square: you can edit config files, probably via (serial or SSH) CLI access
:black_medium_small_square: you've made a backup copy of /etc/board.json already, or you're confident you can regenerate defaults using /etc/board.d/* later
Replace /etc/board.json with the following. Note that by doing this, you're not configuring anything. /etc/board.json is only meant to describe hardware properties and defaults. The changes to roles and network are just for internal consistency. Nonetheless, you should put your own unit's MAC address in network:*:macaddr.

Hi mate your wan on the hh needs to be in dhcp moad . That will let your VM hub give the BT HH a IP adress. By changing the VM hub in to modem moad it stops being a router and acts just as a modem. If you reset openwrt on the BT HH it will work with the VM hub rite out of the box. Leve the firewall settings as they come unless you know what you are doing.

Pleas make shure you have the latest OpenWrt flashed to your router. Latest is OpenWrt 18.06.1

Hi Tapper, thanks for your help, but all is sorted now. Found a really good manual on

Thanks again

1 Like

@Pav If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)