Vi error on new build (18.06)

When I try to edit some files in vi, as soon as i do a backspace or us "dd" to delete a line, vi removes large portions of the file and replaces them with "^@^@^@^@^@^@^@^@^@" characters.

I have checked my terminal settings and done everything I can think of. I cant seem to find any information online other than "^@" may represent a linefeed character.

any ideas?

Could you try to revert;a=commitdiff;h=696c511fb480be04a0ab4563b06b5e1b0d7eb684 or alternatively (if you know how to recover/failsafe your box) try to downgrade to busybox from OpenWrt 18.06 and see if it makes a difference?

im using busybox vi from 18.06 (BusyBox v1.28.4 () multi-call binary.)

Tried installing nano from opkg, but it wont run (perhaps because I am using uclibc instead of musl?)

Which version of OpenWrt are you using?
Hopefully 18.06.2 (or a newer 18.06.2 build), or a master snapshot...

Note that if you use a non-standard libc (like uClibc), none of the opkg installable packages will work properly.

I'm on the 18.0.6 branch, .121 is the latest I've pulled. I'd prefer to use musl but have some compiled, custom libs that I have to use, and don't have access to the source. Not sure that that has anything to do with vi though. Also didn't realize it kills opkg but that's ok for my purposes.

So, installed nano, and it does the exact same thing?!
I am on a mac so tried sshing from a debian vm and its the same behavior. Same behavior with a serial uart connection as well.

Using the vi commands "x" or "dd" also results in the problem, so it's not the backspace button itself.

Bumping this. Have updated to lates 18.0.6 and still have this problem in vi serial, nano, vi ssh.

Unable to figure out a way to make the term work correctly. On older openwrt all those editors work fine.

I can't reproduce the issue.
Check the on-screen keyboard from your PC and from the VM.

my minicom over serial has always ( i think ) ... done this...

generally bash and or ssh and or vim works fine for me tho'... i think its a columns / rows thing.... less likely... terminal character mapping...