Very, very bricked D-Link DIR-645 A1

Help! My router is bricked! I tried reverting back to the original firmware of my router (the D-Link DIR-645 A1) and it just didn't respond after that. I tried everything: connecting to the page, factory reset, recovery mode but they all didn't work... Can anyone help me here?

if does not help, a rather old router roughly worth 1 $ is dead, unless you are into soldering, in this case the TFTP process might be the only remainig tiny chance to get it back working, but that also nees a still intact boot loader just like the recovery GUI.

I have never seen a dlink recovery GUI failing, as long as you avoid other risky command line flashing stuff. Did you set a static PC IP-address and access the recovery router IP as described?

Yeah, I set my pc's IP address to and I tried to go to

is the LED blinking while booted in recovery mode? If it does, its a good chance recovery mode is still sane.

i dont own a 645, I would also try other IPs for recovery access: instead of 101, I own dLink routers that use that IP. Subnet

also remembering that maybe only the first LAN or the WAN port might work on some dir‘s for recovery, you might try that as well.

I actually can't do anything when the router starts up: the earth LED just flashes. (the earth LED is outlined in red in the picture shown)

UPDATE: it worked now!!

For reference, which one of picos suggestions worked?

The recovery mode thing: I actually sent the router to a friend to see if he could do anything but it didn't work for him. But, once i tried it myself, it worked.

on this device the boot loader won't try to setup the switch
so it's random how it powers up in recovery
also this is common if you badly configure the switch
you have let it completely power down say 5 mins
& go straight into recovery
you may have to repeat this a few times

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.