Very Low throughput on one of the IP

The above is my network, I am getting 13 mbps constant throughout on Altai(192.168.0.7) side where 1.5 mbps on Nano M5(192.168.0.3), is there any way to assign equal bandwidth on all IPs?

Is this a limitation due to distance or obstacles, or due to competition between the bridges? If you disconnect the Altai, how much throughput does Nanostation get?

1 Like

I have checked wireless link and it is working properly on both stations, wireless link state is good, i think its issue with bridge, OpenWrt maybe allocating speed according to Physical Interface not by IP, I guess.

How much throughput they get if they are connected individually?
Are they connected to the same radio and the same SSID?

They are connected to the same radio.

It is not helpful to answer only one question out of the three. Take your time to gather the information needed.

2 Likes

My apologies. They are connected to the same radio and same SSID, when one of the radio is down other gets better throughput but when they both are up at the same time, one gets higher than other all the time.

Is the Altan closer to the AP or with less obstacles? Does it have stronger signal than the Nano?
By default there is no bandwidth allocation among the wireless clients. But a client with stronger signal could get higher throughput.

1 Like

00:19:BeXXXX:BF is Altai C1an and other is NanoStation M5.

Alright, there doesn't seem to be any reason for reduced speed on the physical layer. Have you installed any QoS or SQM or something like that in OpenWrt?

Actually I have SQM QoS package installed but disabled.

SQM with cake should provide fair sharing of bandwidth among the hosts. Could you try to enable it and give it a try?
Post here tc -d qdisc ; tc -s qdisc before and after you enable it.

Before SQM enabled.

After SQM enabled:

root@SKYNET:~# tc -d qdisc
qdisc noqueue 0: dev lo root refcnt 2
qdisc htb 1: dev eth0 root refcnt 2 r2q 10 default 12 direct_packets_stat 9 ver 3.17 direct_qlen 1000
qdisc fq_codel 110: dev eth0 parent 1:11 limit 1001p flows 1024 quantum 300 target 5.0ms interval 100.0ms ecn
qdisc fq_codel 120: dev eth0 parent 1:12 limit 1001p flows 1024 quantum 300 target 5.0ms interval 100.0ms ecn
qdisc fq_codel 130: dev eth0 parent 1:13 limit 1001p flows 1024 quantum 300 target 5.0ms interval 100.0ms ecn
qdisc ingress ffff: dev eth0 parent ffff:fff1 ----------------
qdisc fq_codel 0: dev eth1 root refcnt 2 limit 10240p flows 1024 quantum 1514 target 5.0ms interval 100.0ms ecn
qdisc noqueue 0: dev br-lan root refcnt 2
qdisc noqueue 0: dev wlan0 root refcnt 2
qdisc htb 1: dev ifb4eth0 root refcnt 2 r2q 10 default 10 direct_packets_stat 0 ver 3.17 direct_qlen 32
qdisc fq_codel 110: dev ifb4eth0 parent 1:10 limit 1001p flows 1024 quantum 1514 target 5.0ms interval 100.0ms ecn
root@SKYNET:~# tc -s qdisc
qdisc noqueue 0: dev lo root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc htb 1: dev eth0 root refcnt 2 r2q 10 default 12 direct_packets_stat 9 direct_qlen 1000
 Sent 29379400 bytes 24947 pkt (dropped 2, overlimits 19180 requeues 0)
 backlog 0b 0p requeues 0
qdisc fq_codel 110: dev eth0 parent 1:11 limit 1001p flows 1024 quantum 300 target 5.0ms interval 100.0ms ecn
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
  maxpacket 0 drop_overlimit 0 new_flow_count 0 ecn_mark 0
  new_flows_len 0 old_flows_len 0
qdisc fq_codel 120: dev eth0 parent 1:12 limit 1001p flows 1024 quantum 300 target 5.0ms interval 100.0ms ecn
 Sent 29283894 bytes 24726 pkt (dropped 2, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
  maxpacket 1466 drop_overlimit 0 new_flow_count 3904 ecn_mark 0
  new_flows_len 1 old_flows_len 1
qdisc fq_codel 130: dev eth0 parent 1:13 limit 1001p flows 1024 quantum 300 target 5.0ms interval 100.0ms ecn
 Sent 15856 bytes 154 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
  maxpacket 182 drop_overlimit 0 new_flow_count 105 ecn_mark 0
  new_flows_len 1 old_flows_len 10
qdisc ingress ffff: dev eth0 parent ffff:fff1 ----------------
 Sent 1569608 bytes 18784 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc fq_codel 0: dev eth1 root refcnt 2 limit 10240p flows 1024 quantum 1514 target 5.0ms interval 100.0ms ecn
 Sent 508994005 bytes 3999765 pkt (dropped 0, overlimits 0 requeues 217)
 backlog 0b 0p requeues 217
  maxpacket 1466 drop_overlimit 0 new_flow_count 415 ecn_mark 0
  new_flows_len 0 old_flows_len 0
qdisc noqueue 0: dev br-lan root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc noqueue 0: dev wlan0 root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc htb 1: dev ifb4eth0 root refcnt 2 r2q 10 default 10 direct_packets_stat 0 direct_qlen 32
 Sent 1832584 bytes 18784 pkt (dropped 0, overlimits 10 requeues 0)
 backlog 0b 0p requeues 0
qdisc fq_codel 110: dev ifb4eth0 parent 1:10 limit 1001p flows 1024 quantum 1514 target 5.0ms interval 100.0ms ecn
 Sent 1832584 bytes 18784 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
  maxpacket 1466 drop_overlimit 0 new_flow_count 5058 ecn_mark 0
  new_flows_len 0 old_flows_len 5
root@SKYNET:~#

I'm confused, how is the OpenWrt involved?

Simply because it's the gateway?

Your screenshot of the AP is Ubiquiti.

Ubiquiti is in bridge(switch) mode. I have 45/45mbps up/down from ISP. When two stations are connected to Ubiquiti AP, one gets higher throughput than other most of the time. This is asymmetric.

1 Like

You didn't configure SQM ever right? It looks to me that it is running on default settings.
There is not much you can try here except to configure SQM and hope for a more fair shaping for the wireless clients. OpenWrt is anyway just in the middle of the path and only forwards packets.

1 Like