Very high ksoftirqd on idle

I've been using OpenWrt for two years now and never had a problem like this before.

I'm using a Xiaomi AC2350 on version 22.03.05 and have next-dns,sqm,ddns and WoL packages installed on the system.

Two days ago, for some reason system started to act weird and have high cpu usage:

So firstly i decided to just flash the same firmware(sysupgrade) on top of it but it did nothing:

Then i performed a reset but again it didn't solve it either. So i tried upgrading to RC version and flashed 23.05.0-rc3 after that situation got improved a little but still nothing like the before and finally i decided to give it a go to the hard reset using the physical button and it improved a tiny bit more but still not enough.

So, right now i have zero packages installed on system and no sqm or anything but still can't even get half of the throughput of my dsl speed and don't know what to do at this point.

Btw on devices connected with cable, things are tad better and WI-FI devices get more hit from this problem/

Ksoftirq can have a high usage i.e. when trying to push more packets then the router can handle/route. Like lan to wan or from one vlan to another vlan. It's this your case?

It can't be from one vlan to another but I also don't think it's lan to wan because so few devices are connected to the network and I know their workload.

But some interesting things happened past twenty minutes:

I absolutely did nothing and left my pc to update some games from Steam and saw that my speed was increasing gradually and came to the point where it should be. So it kinda solve itself?? I don't know.

Now I'm going to install my packages i mentioned before to see if any one of them is affecting the system. I suspect it's due to some misconfiguration from SQM but not confirmed it yet.

Btw i had enabled software flow offloading from the beginning

But... if you say you had a running download AND you modified queuing.... then isn't it that routing is involved....? Btw what's your Internet connection speed?

I had a running download but didn't modified queuing after i had problem. most of the timei I tried to solve the problem on bare openwrt installation, nearly nothing changed or installed on it.

My dsl speed is 79 mbps but mostly 72-73 is usable.