VDSL via DM200 and WRT3200ACM

Hi guys,

Sadly, I'm a noob - but I have been trying and failing for hours and hours.

The long and short of it is, I can set my DM200 to modem & router mode, set to DHCP and then put in a client ID, and everything works fine. This device does not have OpenWRT on it. When I set my DM200 to modem only mode and pass the connection to my 3200ACM, I am getting nowhere.

I've read many conflicting ideas and reports - but my initial instinct was that my 3200ACM (router from here on) would just do the same DHCP job that the modem was doing previously. No joy, everything seems fine and it even seems to show packets sending and receiving but there is no connection at all under 'Network, or pinging in diagnostics.

I then read something about actually using PPPoE on the router side, so I have tried that. I have no PPPoE details for my provider (Sky - UK) but after some research I found something to use. This gives me no packets and an error "Unknown error (USER_REQUEST)".

I've tried a lot of things and fiddled with just about everything but there could be something I just don't know or have missed in my searches. That is why I am here, because I am a noob and am unsure what to do next. Any pointers or ideas would be greatly appreciated.

Late notes : I read something about the DM200 firmware, I have tried old and new. Also I am unsure about which physical interface I am to select for my WAN device. I assume it is eth0 but I have tried them all.

Thank you very much for your time and I apologise if I've missed something obvious!

You most likely forgot to set the vlan tagging right.

It was my understanding that the default VLAN tagging was how it needed to be - is this incorrect and I need to make changes, then? Thank you for your response.

Edit: I see through some further research that I need VLAN ID 101, with priority 0. I assume this comes into the VLAN tagging somehow with OpenWRT. Obviously on my DM200 native firmware there are input fields for VLAN ID etc.

@mbo2o I will contact my ISP today and try to get some more concrete details for PPPoE, thanks

Sky/NOW in UK do not use PPPoE.

Sky uses MER protocol. This may help once you have resolved your VLAN 101 tag issue:


Retrieved from OpenWRT wiki:


Thank you ever so much, I feel silly for not finding that page on the wiki now! I'll give it a go when I get home tonight.

Edit: followed the guide and worked a treat, I needed to figure out my Client ID the way the guide said. Thanks so much @bill888