VDSL-SuperVectoring and TD-W8970B

#1

Hi@all,

my provider (easybell (Telekom reseller)) recently switched from an old VDSL2 DSL-AccessMultiplexer (50/10 Mbit/s) to the brand new ADSL SuperVectoring boards that enables 250/40Mbit/s.
Before the change my TP-Link TD-W8970B connected just fine with always the maximum booked speed of 50/10Mbit/s.
However after the change the maximum sync that is possible is now 20/1.5Mbit/s.
I read a lot about this problem and it seems to be a default fall back profile for 30a enabled line cards. So DSL modems that don't support vectoring will be downgraded to this profile to prevent interference with all the other vectoring enabled modems that are connected to the same cable harness.

I'm awear that the default firmware of the TD-W8970B that comes with the stock LEDE doesn't support VDSL Vectoring aka G.993.5. So I tried to get one of these here working: https://xdarklight.github.io/lantiq-xdsl-firmware-info/
I tried the Speedport and the FritzBox based dsl firmware blobs but none of these enabled the Vetoring functionality even though they were listed as "incl. vectoring support".

Does somebody tested this in germany on a Telekom DSL-AccessMultiplexer?
Maybe I just had bad luck. Which blob shall I use?

0 Likes

#2

maybe this helps...
https://lists.openwrt.org/pipermail/openwrt-devel/2018-September/014094.html

i had the same problem and opened a ticket with the isp, then a support-guy measured the line and switch me to another port. works for now with the vmg1312

0 Likes

#3

The technician is ordered for Friday. So maybe this will help. I already tried the Speedport W921V firmware however the 1.39 isn't available for download anymore. I used the 1.44.
Could you send me your blob so I could try this one?

0 Likes

#4

Can't answer for use in Germany, but the DSL firmware blob from the Netgear DM200 v1.0.0.52 OEM firmware (linked from the xdarklight info) works with G993.5 connections here in Australia (profile 17a, Annex A - i.e. over POTS - but with Annex B band plans and tone sets).

0 Likes

#5

Is there a way to see the capabilities of the currently running firmware?

I already tried the DM200 firmware for Annex B which is used here in Germany. Unfortunately it still doesn't work. The technician who was here today could connect via G.993.5 (Vectoring). But my TP-Link still can't :frowning:

0 Likes

#6

Post your /etc/config/network, you might have something else set wrong.

0 Likes

#7

I assume you mean the tones?

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config dsl 'dsl'
        option tone 'bv'
        option annex 'b'
        option xfer_mode 'ptm'
0 Likes

#8

Yes. I have tone 'av' and annex 'a' set on mine since I'm running 5.7.9.5.1.7-5.7.3.F.0.1 (xcpe_579517_573F01.bin) which is an Annex-A firmware. However, I just saw that my successfully connected 100 profiled out of 175 possible mbit line is still G.992.3, not G.993.5, so my opinion may not be worth much anyway. :confused:

0 Likes

#9

The VRX200 SoC does not support the 35b profile (super vectoring), it only supports up to the 30a and 17a profile.
When I use the non vectoring FW I also only get 15 MBit/s on my Deutsche Telekom line, you have to switch off your device for about 1 minute and then boot up with a vectoring capable FW (the version ends with a 7).
Deutsche Telekom says that changing back to vectoring needs manual changes by them for some DSLAMs.

0 Likes

#10

@hauke: Does this mean that a vectoring enabled VRX200 can be run on a Super Vectoring enabled line? My DSLAM was upgraded from 17a VDSL to 35b Super Vectoring. Without the intermediate step of normal Vectoring. I already tried to disconnect the modem physically. My current stats are:

ATU-C Vendor ID:                          Broadcom 192.85
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.7.6.10.0.7
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 47
Errored seconds (ES):                     Near: 9 / Far: 19
Severely Errored Seconds (SES):           Near: 0 / Far: 11
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 11
Unavailable Seconds (UAS):                Near: 25283452 / Far: 25283452
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 19 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Fast (0.15 ms) / Up: Interleave (9.0 ms)
Data Rate:                                Down: 19.245 Mb/s / Up: 1.460 Mb/s
Line Attenuation (LATN):                  Down: 6.0dB / Up: 2.8dB
Signal Attenuation (SATN):                Down: 6.0dB / Up: 2.8dB
Noise Margin (SNR):                       Down: 5.1dB / Up: 8.4dB
Aggregate Transmit Power (ACTATP):        Down: 12.8dB / Up: 4.9dB
Max. Attainable Data Rate (ATTNDR):       Down: 19.850 Mb/s / Up: 1.496 Mb/s
Line Uptime Seconds:                      1382920
Line Uptime:                              16d 0h 8m 40s

This should be one of the vectoring enabled firmwares as it ends with a 7.

0 Likes

#11

The VRX200 does not support the 35b profile, this is a hardware restriction. The VRX518 and later support the 35b profile.

This looks like some fallback profile you are in, you could try to disconnect your DSL line for 5 minutes and boot the device again, if you are lucky it will at least use the 17a profile with vectoring.

0 Likes

#12

So it isn't connecting with vectoring enabled.

Hmmm... that version is from an early Netgear DM200 firmware which wouldn't work on the NBN vectoring VDSL2 implementation in Australia - the DM200 had to wait for a later version to be usable here. The DM200 v1.0.0.52 firmware works here and the driver file extracted from it (file version 5.7.B.5.0.7-5.7.5.4.0.1 listed on xdarklight) has worked in OpenWrt for myself and some others connecting to NBN - have you tried it?

0 Likes

#13

Are you sure this will work in Germany? We use Annex B. So I assume it doesn't make sense to test an Annex A firmware!? Am I wrong in this? What's the corresponding Annex B version of the firmware you suggested?

0 Likes

#14

"Annex A" or "Annex B" only refers to the ADSL parts of the firmware.

0 Likes

#15

Have you set your wan-device to vlan id7? For your wan interface you need to use dsl0.7 as device, instead of dsl0.

See here

0 Likes

#16

@stonerl: Yes, VLAN ID=7 is set on the WAN interface. Otherwiese it wouldn't work with the slower speed which it is synced at the moment.

0 Likes

#17

@Takimata: Yes exactly. But the recommended version by pythonic is for Australia and tagged as "Annex A" which the provider in Germany don't use. They use Annex B. So I will definitely need an "Annex B" firmware version.

0 Likes

#18

No. The VLAN ID matters for PPPoE, it has no bearing on the line synchronization itself.

No. Your line is VDSL, it does not care about the ADSL Annex.

0 Likes

#20

Of course not, but I know someone else in another thread tried it and it worked for them. There is no separate Annex B version of the DM200 as far as I can tell, so if Netgear is selling it in Germany I expect it to support that environment and the available GPL source suggests that it supports at least some German ISPs. Even though Australia is Annex A at the hardware level, the NBN VDSL implementation favours the Annex B tone sets/band plans and the firmware will report connecting in Annex B mode if the Annex option is left at auto.

0 Likes

#21

The latest firmware can be found here.

vr9-B-dsl.bin:
VDSL over ISDN incl. vectoring support for VRX200, version: 9.1.4
ADSL Annex B for VRX200, version: 9.0.D

I'm using this one without any problems and working vectoring on a Telekom 100Mbit line.

1 Like