VDSL modem WAN bridge with openwrt router

So, I was using my vdsl modem with my openwrt router in bridge mode for more than 2 years. There was an issue with IPTV streaming, there was stutter in the stream. I was not able to solve this issue.

There was also an issue with pppoe WAN connection, SQM was not working properly. Even with setting my speeds 90% of the ISP provided speed, there was ping spike and stutter in the video games when other people were streaming or downloading stuff.

I was finally able to fix these issues and it was an issue with my bridge WAN connection setup in the vdsl modem and openwrt router. And I am sharing here with the people if they ever face such an issue with their bridged WAN connections.

I was creating separate bridged WAN connections with VLANS in the modem. Instead of creating just a single WAN bridge connection without mentioning any VLANS and creating separate VLANS for IPTV and WAN pppoe connection in the openwrt router. After that all my issues of IPTV stream stutter and high pings even with SQM (now using Qosify) are gone.

I hope someone will find it helpful.

WAN bridge connection in the modem with VLAN and without VLAN.

openwrt Router settings with VLANs

 cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd74:3bca:1fc1::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'

config device
        option type '8021q'
        option ifname 'eth1'
        option vid '10'
        option name 'eth1.10'

config device
        option type '8021q'
        option ifname 'eth1'
        option vid '20'
        option name 'eth1.20'

config interface 'WAN'
        option proto 'pppoe'
        option device 'eth1.10'
        option username '*********'
        option password '*******'
        option ipv6 'auto'
        option peerdns '0'
        list dns '8.8.8.8'
        list dns '8.8.4.4'
        option mtu '1500'
        option ac '**********'

config interface 'IPTV'
        option proto 'static'
        option device 'eth1.20'
        option ipaddr '10.10.10.1'
        option netmask '255.255.255.0'

config interface 'modem'
        option proto 'static'
        option device 'eth1'
        option ipaddr '192.168.10.5'
        option netmask '255.255.255.0'

config device
        option name 'eth1'

config interface 'wan6'
        option proto 'dhcpv6'
        option device '@WAN'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        list dns '2001:4860:4860::8888'
        list dns '2001:4860:4860::8844'
2 Likes