VDSL Modem bridge mode connected to WNDR3800 Router with OpenWrt [no internet IPoE]

Hi all,

Big fan of this forum for the last few days. I have tried reading many guides here to no avail for my issue. I am unable to get an internet connection from the router which is connected to my bridged modem.

I have the following particulars:

  • VDSL connection through ISP AussieBB. (IPoE)

  • DLINK Modem/router DSL-G225 in bridge mode

  • Netgear WNDR flashed with OpenWRT 19.07

  • Modem is connected to the router via ethernet to the WAN port.

  • Modem on

  • Router LAN set to

  • Modem @WAN in OpenWRT networking set to DHCP
    (WAN Showing the same).

I have followed the steps to connect my modem to the router in the guide here: https://openwrt.org/docs/guide-user/network/wan/access.modem.through.nat
I have also tried to use this guide to troubleshoot: Can't access DSL modem in bridge mode - #5 by tombadog


  • I can ping my modem via the router (The modem is reachable from any host in the LAN)
  • Cannot ping internet via router
  • If I connect my bridged modem directly to my PC, I have an internet connection where I am assigned an IP and DNS by the ISP

I am almost certain it's something I am missing in OpenWRT. I have not done anything different to the recommendations in the guide: https://openwrt.org/docs/guide-user/network/wan/access.modem.through.nat#web_interface_instructions

However, I have tried tweaking different things as per other guides before refreshing all settings and starting again with some guidance from the ISP.

I'm stuck after many hours trawling through other queries. Obviously a knowledge gap here. Would appreciate any assistance, even another guide - thanks in advance.

My DSL modem's admin page is on the lan (router-on-a-stick). Bell internet in Canada is pppoe on vlan35, trunked on the lan. The modem handles trunking but not all routers can handle trunking.
I donated my WNDR3800 last Satuday.
I'm guessing that eth1.100 is your wan port, vlan100 for Australia.
On the Switch page, change vlan2 to vlan100 and tag the cpu and wan ports.

Thank you, murraydr44!

I hadn't done anything on the switch page up until your message. I'm not seeing a WAN port on my switch page and there was only one port status entry (1). I did try adding a new VLAN ID entry at 100 as you suggested and tagged the CPU port only (as I don't have a WAN port displaying) - this did not work, however I am willing to give it another go.

I restored my router to default settings and took my modem out of bridge mode. My modem is still on a different subnet to the router. I connected the router to the modem and am using it as an access point - which is not ideal. I just plugged the modem into the router's WAN without changing any of the other default settings and internet was accessible instantly.

I'm going to do a lot more reading in the meantime. Appreciate your help.

1 Like

I still think eth1.100 is a viable WAN port for you. The RTL8366 switch is eth0.
This WAN port hassle is one reason why I donated my WNDR3800. The other 3 reasons are flash memory access times, power dissipation and age.
The hard part is changing eth1.1 default to eth1.100 . Luci can't help us here.
Could you upload the results of uci show network from your router?
I use Putty or Tera Term.

ssh WAP2100.lan (my router)
root@WAP2100:~# uci show network
network.wan.device='eth0.2' - factory setting
network.wan.device='eth0.35' - vlan35 modded for Canada

ssh WNDR3800.lan (your router, simulated)
root@WNDR3800:~# uci show network
network.wan.device='eth1.2' - factory setting
network.wan.device='eth1.100' - vlan100 modded for Australia

vi /etc/config/network and reboot to make the new settings permanent.

This passes vlan100 to the router's WAN port reliably.
On the DSL-G225 Ethernet WAN Connection page,

Protocol: Bridging
Enable Multiple Vlan Over One Connection is checked.
802.1P Priority (0-7): -1 
802.1Q VLAN ID [0-4094]: -1 (internet vlan100 will remain tagged for the router)

It is still possible to untag vlan100 at the modem instead of the router's WAN port.
On the DSL-G225 Ethernet WAN Connection page,

Protocol: Bridging
Enable Multiple Vlan Over One Connection is checked.
802.1P Priority (0-7): 8 for Australia (0 for Canada)
802.1Q VLAN ID [0-4094]: 100 for Australia (35 for Canada)

This should untag vlan100 to vlan1 for the router's WAN port, hopefully.
Maybe the modem has to be rebooted to get it to work.
I don't expect it to work on the first few attempts.
The ISP's MAC address lock may have to be reset to get it to work.