V18 slower ping than v17

please take a look at the screen shot

I used to have all three devices on v17 ping response was 15ms to google i thought it was time to upgrade but thought i'd test it first

i upgraded one and saw slower response times so thought i'd build from source and get rid of luci and to see if it help performance (its the same)

i have 3 identical wifi AP's i have one on version v17 lede and two on v18 they are all on the same switch and all have the same length of cable

one is a snapshot of v18.06.0-rc2 i built myself from source with minimal installed no luci or anything special just to test

the other is v18.06.2 tiny from the repo

before i put v18 on them v17 was giving me a better ping after i upgraded response time has doubled

any clue whats wrong i can provide configs if needed but initially they were all on the same config, is there something i'm missing in v18 i need to set compared to v17

hardware is TP-link TLWA801ND v2

screenshot says it all really

You are pinging different servers.
One domain name doesn't mean one server.

3 Likes

ok pinging the same ip now same result

Provide reasonable statistics and diagnostics for each device:

opkg update
opkg install mtr
mtr -w -b -c 100 openwrt.org

ubus call system board
ls -l /sys/class/net/*/device/driver
2 Likes

I pinged both servers form my side and got same result for both server. So it's likely that the difference comes from the different version (probably different driver). But then again, 15m isn't significant when using such routers.

2 Likes

i was more curious as to whether there was a new setting i might be missing or if there was a known issue, i don't think an extra 15ms is going to hurt, the access points are just for 6 pda's to hit a DB to request product data, via barcode all they upload is a small string to the web servers api and download a single image and about 200 characters

i'd prefer security, stability and long running time over 15ms :slight_smile:

1 Like

will hopefully get time to get the device drivers today, as I was thinking of upgrading a different device today and setting up something like wifidog on it, while i'm waiting for my router image to compile i'll get mtr installed on these 3 tp-links

i suggest you double check your config and/or try with a default-config.
maybe some interface name changed?
this looks not ok.

root@Wifi-POINT2:~# ubus call system board
{
	"kernel": "4.9.152",
	"hostname": "Wifi-POINT2",
	"system": "Atheros AR9341 rev 3",
	"model": "TP-Link TL-WA801N\/ND v2",
	"board_name": "tl-wa801nd-v2",
	"release": {
		"distribution": "OpenWrt",
		"version": "18.06.2",
		"revision": "r7676-cddd7b4c77",
		"target": "ar71xx\/tiny",
		"description": "OpenWrt 18.06.2 r7676-cddd7b4c77"
	}
}
root@Wifi-POINT2:~# ls -l /sys/class/net/*/device/driver
lrwxrwxrwx    1 root     root             0 Apr 17 08:07 /sys/class/net/eth0/device/driver -> ../../../bus/platform/drivers/ag71xx
lrwxrwxrwx    1 root     root             0 Apr 17 08:07 /sys/class/net/wlan0/device/driver -> ../../../bus/platform/drivers/ath9k

root@Wifi-POINT1:~# ubus call system board
{
	"kernel": "4.4.71",
	"hostname": "Wifi-POINT1",
	"system": "Atheros AR9341 rev 3",
	"model": "TP-Link TL-WA801N\/ND v2",
	"release": {
		"distribution": "LEDE",
		"version": "17.01.2",
		"revision": "r3435-65eec8bd5f",
		"codename": "reboot",
		"target": "ar71xx\/generic",
		"description": "LEDE Reboot 17.01.2 r3435-65eec8bd5f"
	}
}
root@Wifi-POINT1:~# ls -l /sys/class/net/*/device/driver
lrwxrwxrwx    1 root     root             0 Apr 17 08:07 /sys/class/net/eth0/device/driver -> ../../../bus/platform/drivers/ag71xx
lrwxrwxrwx    1 root     root             0 Apr 17 08:07 /sys/class/net/wlan0/device/driver -> ../../../bus/platform/drivers/ath9k
root@Wifi-POINT1:~# 

so i did a diff on the configs the only difference is iproute2 on v17 and the v18 system there is no dnsmasq.conf

oh and v18 has this extra in the wifi conf

option country 'GB'
option legacy_rates '1'

but my pings are from the terminal on the device think i just have to live with it.