UTF-8 (Hebrew) filenames scrambled in samba share on both windows and Mac

I have tried sharing a (FAT32) external hard drive on my router. On OpenWrt the mount point shows (correct) as "vfat". Somehow on my local computers Hebrew file names get scrambled. Seeing for example "_9AH8C~1.PDF" instead of a file name in Hebrew.
When I connect the hard drive to my local computers the file names show correctly.

I think I have set up Hebrew support correctly with adding packages:

  • kmod-nls-cp862
  • kmod-nls-utf8
  • kmod-nls-iso8859-1
  • kmod-nls-iso8859-8
    Something is missing maybe?

In the Samba Version 4.14.7 Network share template I tried changing "unix charset = [CHARSET]" to:

  • unix charset = UTF-8
  • display charset = UTF-8
    But that did not help.

This may be related to a VFAT issue.

Try to use FAT32, or better, exFAT which can be read and write by everything (win, mac, linux).

Thanks, but yes, the disk is formatted as FAT32 and on Luci the mount point shows as vfat. I will edit the original post to reflect it.

If the disk is mounted as VFAT, than the disk manager may only read 8+3 shortcut filenames. Try long filenames in ascii, just to see if they are read correctly.

Better format in exFAT. It natively manages UTF8 and long filenames, and should be well recognized by Linux kernel.

Thanks, I reformatted the drive to exFAT. That worked!

1 Like

If the disk is going to stay attached to the router, consider formatting it with ext4.
Otherwise (use with win and mac), exFAT is the better universal choice.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.