Using two OpenWrt Linksys ea6350v3 routers as a main router and wifi bridge


I'm trying to set up a network at home, where I have as the title suggests two linksys ea6350v3 routers. The first one connects over ethernet directly to the isp router. The second one is on a different floor and will act as a wireless bridge to enable a NAS and a few wire-only devices to have internet access. Both routers have OpenWrt flashed on them. The main router is able to span a 2.4ghz and 5ghz network and the idea was to use the 5ghz network dedicated to rout traffic between both routers, while wireless clients will use the 2.4ghz ones to connect. The problem I'm running into is that the bridge router can connect to the main ones' 2.4 or 5ghz net, but does not have internet access itself. I have tested if it is a connectivity issue, but that doesn't seem to be the case. I have also tried having the bridge router on a different subnet as well as disabling the bridge routers' dhcp functionality. Do you have any ideas what can be the problem? As an additional test I have tried connecting to a poe repeater connected to the isp router (outside of the described network) and there it seems to work fine. The main router is with the default openwrt settings barring the created wifi networks. Cheers!

What instructions did you use to create your openwrt 'wireless bridge'?


See also section 9.10 of OpenWrt installation guide for HH5A for more detailed relayd instructions which I've used on EA6350v3 and other routers.

Relayd works fine on ea6350v3 last time I tried it with OpenWrt 19.07 snapshot last year, but maximum throughput was lower than using Linksys OEM firmware over 5 GHz bridged to my main ISP router. Can't remember the actual figure. Maxes out at 120 mbps with relayd.

Only gripe I have about using wireless bridge mode with Linksys firmware, is it takes almost 2 minutes to boot EA6350 v3 and connect to my main router.

Thanks for the info! I'll look into it. I've relied on a couple of guides

and a youtube video

but as I was working out the details, I figured that I'm failing to get my router to have internet access in the first place. In the beginning I was able to get clients connected over wireless to the bridge and have internet somehow, but not over ethernet and not the router itself. I think I'll go ahead and try to install the relayd over the poe extender and then try to set it up that way. I'll come back to this thread with the results. About the throughput it shouldn't be that big of a deal in my case as I think I'm getting better signal with openwrt. Also over 5ghz I can actually access completely unused higher frequency bands, which are not available with the standard firmware.

So I did try the instructions from the video after installing relayd and the luci-relayd packages and on the part of configuring the vlan i stumbled onto this message Interface "lan" device auto-migrated from "eth0" to "eth0.1". as soon as i switched the CPU (eth0) to tagged. For reference there is no CPU (eth1) and the router becomes inaccessible after that. After a bit of searching I found this thread IPQ40xx Switch Config "Strangeness" which describes the issue, but so far no solution is to be had. Do you know how you set up your vlan to work with relayd?

Do not change the interface names or switch configuration when configuring relayd. It should work with default switch (vlan) configuration for EA6350v3 when I tried relayd with openwrt 19 snapshot last year.

Did you study section 9.10 of the Installation guide for HH5A ?
ie. clear your openwrt settings and try again following above guide.

(vlans don't work properly with ipq40xx devices with OpenWrt 19)

I just flashed 19.07.3 onto my spare EA6350v3 that was running Linksys OEM firmware.

Following Installation guide for HH5A to install and configure relayd with these parameters.
wwan static IP: (on same subnet as my main OpenWrt router) and correct gateway and DNS settings.
Relayd bridge configured to connect to my Linksys WAP (OEM fw) using 5 GHz wifi
PC client wired via ethernet to EA6350 relayd bridge.

PC has no issues retrieving IP using DHCP from main OpenWrt router via the relayd bridge to my Linksys WAP. PC can access internet via the relayd bridge. All working as far as I can see.

OpenWrt 19 does not properly support VLANs in IPQ40xx devices. Do not edit 'Switch' menu in LuCI

Here are default switch settings in /etc/config/network. Do not change these values.

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'`

Only 2 issues I encountered was when trying to change the LAN IP of OpenWRT from default to The 'Apply Unchecked' banner message didn't appear (Frequent issue since openwrt 18). I was about to SSH into the router to manually edit the /etc/config/network file, but the LAN IP change went through on 3rd attempt/reboot.

Also, after installing relayd package, I had to reboot the OpenWrt router to be able to see & select the relayd protocol. (New packages install bug in 19.07.3 LuCI ?)

1 Like

I'll take a look. I somehow managed to overlook the dropbox folder. Sorry about that!

I recommend a WDS bridge instead of relayd:


Doesn't WDS act as a repeater effectively halving my bandwidth?

The bandwidth is halved when wireless clients use the same channel as the link between the routers.
This is independent of the type of bridge (relayd or WDS).
Since you are using different bands, the full capacity is available.

Okay, thank you for clarifying this. Then am I correct in assuming that if I use the 5ghz network as the backbone for the WDS AP and Client and the 2ghz as the one available to connect for wireless devices then it's pretty much impossible for this effect to be present? Are there any other benefits to use WDS besides being able to have a single network spanned by the two access points through WDS? From what I know, the clients will not proactively change the AP as long as they are connected regardless of signal strenght, which means that if I am connected on AP2 and then move right next to AP1, even though AP1s signal is stronger as long as there is a faint signal from AP2 my device will not switch between access points.

To get back to bill, the tutorial worked flawlessly and I'm now replying by using internet provided by the bridged router! Thank you for your help! I do have to emphasize to whoever might be reading this to take heed when the tutorial says to disconnect and reconnect the lan cable between the bridge and the pc you're using to set this up. Eventually the IP will refresh and you can proceed.

fwiw, @mpa suggestion to use WDS looks to be a more elegant and simpler solution than using Relayd particularly as you are using two Atheros based openwrt routers. Perhaps maximum throughput is improved too? I cannot test WDS because my Linksys EA6350 v3 WAP is using OEM firmware which does not support WDS. (I don't use openwrt as WAP because I have discovered some of my 2.4 and 5 GHz wifi devices are not compatible with ipq40xx openwrt wifi, but work OK with Linksys OEM fw)

I believe you are correct with regards to your queries about 2.4 GHz client using 5 GHz backbone, and 'roaming' between AP1 and AP2.

I wouldn't expected maximum throughput to change much, but WDS/ 4addr is a lot more reliable (relayd is completely broken with IPv6 traffic, this is not an issue with WDS/ 4addr).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.