Using thuraya so-2510 as GmPRS/GPRS modem

Hello
Im new with openwrt and would like to use my thuraya so-2510 satellite phone with openwrt to get data/internet connection
I was trying to configure the device with my openwrt router
Read some pages and watched some videos trying to learn how to identify and configure the satellite phonee with my router so i can make gprs/gmprs connection
First it was showing as fast speed usb device

Installed some opkg packages and i found out that (kmod-usb-acm) package is the only package that connected thuraya so-2510 device was responded now it's showing in system log as CDC-ACM device (ttyacm0) also it's showing in interface devices list

Now im not sure if that is enough and it should be completely identified and need no more drivers

If this means it's ready to make connection im still have problem to make the connection configuration ,what protocol should i use and where to enter the required configurations such as (dial number.....etc)

Any one have experience with such a device before

Router used : tp-link mr3020/hardware version 3.20
Openwrt version: openwrt-23.05.4-ramips-mt76x8-tplink_tl-mr3020-v3-squashfs-sysupgrade.bin

I am not an expert but I believe you can try package: modemmanager

1 Like

Show the output of cat /sys/kernel/debug/usb/devices

1 Like

APN name is GET , rest looks like AI translator went rogue down to text making no sense.

dmesg

Talk to modem using minicom and modem response correctly

It is "get" but in CAPS.
And disable ip6 if it disconnects.

1 Like

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

all this info, yet you failed to post what was requested a day ago...

I will change the APN to capital letters (GET)

And thank you to warning me brada about mac/ip/passwords and personal data

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd9e:92b7:855e::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 6t'

config interface 'wwan'
        option proto 'dhcp'

config interface 'tt'
        option proto '3g'
        option device '/dev/ttyACM0'
        option apn 'get'
        option dialnumber '*99#'
        option ipv6 'auto'
        option service 'umts'
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key '11221122'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'tommy'
        option encryption 'psk2'
        option key '13tommy13'
        option disabled '1'
root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wwan'
        option interface 'wwan'
root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'
        list network 'tt'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.162",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7628AN ver:1 eco:2",
        "model": "TP-Link TL-MR3020 v3",
        "board_name": "tplink,tl-mr3020-v3",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.4",
                "revision": "r24012-d8dd03c46f",
                "target": "ramips/mt76x8",
                "description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
        }
}

Thats not my thing, thats collaborator template, so thanks goes to site admins/mods who authored it :wink:

1 Like

You have rather limited flash memory, like insufficient to utilize phone as WAN backup, so you will need to click wwan off and mobile on every time you need.

Detailed info:
https://openwrt.org/docs/guide-user/network/wan/wwan/3gdongle

option ipv6 '0' seems needed if error still persists after changing APN.

Basic theory of operation is that you "dial" the packet modem and it handles the cellular network providing you packets via ppp protocol.
If the parameters are not correct for packet network (the get/GET) then it chokes later down the road after "dialling" modem itself. Like 1s later just disconnects.

EDIT: the step further will be to add pppd debug messages and adapt system so it can capture them without crashing filling small memory.

https://openwrt.org/docs/guide-user/network/wan/wan_interface_protocols#protocol_ppp_ppp_over_modem

option pppd_options 'debug'

EDIT: corrected config line.

1 Like

LCP debug messages show very detailed ppp protocol trace. Like other side rejecting compression etc.

No, there follows ppp connection negotiation.

1 Like

Do you have data service?

If u mean data service on the sim card (internet service) yes i do have also i test connection on windows xp and it works fine

The trace up to pppd start looks normal. Can you enable windows ppp trace and compare and try to replicate ppp connection features?
Maybe provider knows? The UNIX pppd is like decades old, you are certainly not first to try it.

1 Like

Thuraya have customized openwrt firmware for tp-link mr3040 named xt hotspot, is it possible to modify it to work with mr3020 or extract the settings to use it?

openwrt-ar71xx-generic-tl-mr3040-v2-squashfs-sysupgrade.bin

Or at least is there any way to install the firmware on virtual machine or somthing like this to extract the settings

Here's the link from official website showing the firmware

https://www.thuraya.com/en/support/upgrades/land-voice/thuraya-xt-hotspot

1 Like

Want to install Desktop Linux (in a Desktop VM)?

binwalk -e -M ....bin

etc/ppp/options
etc/chatscripts

....