Using router as extender using WAN

I'm using the browser, how do I get there?

Also thanks, I'm new sooo yeah.

You don't, I gave instructions for the command line.

Feel free to just take relevant screenshots.

Also, please answer the inquiry, it matters:

(Also, in case you're using Netgear references, maybe I should note that the WAX202 is setup as a normal router once OpenWrt is installed.)

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option band '2g'
	option cell_density '0'
	option channel 'auto'
	option htmode 'HE40'
	option country 'US'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
	option band '5g'
	option cell_density '0'
	option channel 'auto'
	option country 'US'
	option htmode 'HE160'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option encryption 'psk2'
	option key '(removed)'
	option ssid 'eGTG2.4'
	option isolate '1'
	option network 'wan wan6'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'eGTG5'
	option encryption 'psk2'
	option key '(removed)'
	option network 'wan'

And I think it's configured in router mode?
I don't know if I should be using it in router or extender mode. I have some smart devices that I want isolated from everything else, but my main router doesn't have a 2.4ghz band, so would using it in router mode be better?

Please enclose output and code into a code box by highlighting it and using the "Preformatted Text" button:

screen226 :point_left:

Again, OpenWrt has no such thing - you configure what you desire from the default config.

There's Wikis and threads on setting up extenders, dumb APs, etc. - so if that's your intent, there's no fruther need to elaborate there.

See: https://openwrt.org/docs/guide-user/network/wifi/dumbap

I haven't tried plugging into the WAX202's WAN and bridging the WiFi to it (in fact WAN isn't setup in a bridge and that's kinda complex to setup on routers with DSA switches like the WAX202 - unless you really need the extra port). I surmise your issue is that WAN doesn't exist in a bridge in which the WiFi can connect.

I would simply connect to LAN, make LAN DHCP client (or set it to an IP on the router's Network), remove DHCP on OpenWrt's LAN too...again there's Wikis and threads on that already.

Best wishes on your setup.

So I would have to connect to my router over wifi? When I was using the 202 with netgear's firmware, it let me use the wan port as a bridge.

No, again:

I assume this would be with the same Ethernet you used to connect the WAN port. Just use LAN1, LAN2 or LAN3 instead. Feel free to follow the Wiki - your question is literally answered in the "TL;DR" section.

(:man_facepalming: You mentioned Netgear again.) OK, feel free to configure it as such in OpenWrt - I just noted it was possible; but you noted you were a n00b, so I didn't want to make things complex. If you insist on using the WAN port also, see:

In any case, you need to configure your interfaces properly. It seems simple just to alter LAN.

Oh I'm sorry I wasn't understanding what you meant. I changed to one of my lan ports and now ethernet seems to be working, but whenever I go to 192.168.1.1, it brings me to my main router's page, how do I access the 202?

I would highly advise following a Wiki or set of instructions from the beginning steps.

Again:

After you fix the IP conflict just created, you would then access the WAX202 via the IP you properly set for the OpenWrt in LAN.

Don't forget to add to the OpenWrt:
Gateway: 192.168.1.1
DNS: 192.168.1.1

I tried connecting through SSH but terminal said connection refused. I used this: https://openwrt.org/docs/guide-quick-start/sshadministration

Would I have to disconnect the 202's ethernet and configure everything and then plug it back in? Can you link me to a guide that shows me how to remove DHCP?

Have you read the Wiki link yet?

(You're asking questions that are steps in the WIki.)

Also, simply just browse to the LAN setting and remove it (once you fix your IP conflict so you can connect).

We established why this was the case already (it's likely your main router - unless you're noting the new IP and you already fixed the IP as suggested, which you failed to mention).

Ok so I configured the router to not use DHCP and when I saved and applied, it kicked me off the page and now I can't connect to it through any LAN or WAN ports.

It still bridges (I think that's the right term) to my router when I plug it in, but I can't access the router's page when disconnected.

Since you won't provide clear information, nor the steps you're undertaking (nor confirm you did what was suggested) - it's very hard to follow.

I assume you never set a valid IP in the OpenWrt's LAN; but you won't provide that information:

What did you change the OpenWrt's LAN IP to?

That's how you would access the device.

Again I'm really sorry. I'm trying my best. I don't have much clue what I'm doing.

  • I think I set the LAN IP in the OpenWrt to 192.168.1.2, which is not used by any other device at the moment.
  • I turned off DHCP.
  • I put in Cloudflare's DNS (1.1.1.1)

My issue now is that I can't connect to the OpenWrt. In my network settings, it shows my ip address and subnet mask but no router ip. I tried the LAN IP I put above to access the browser, but it says no internet. The SSH also can't be accessed with that IP.

OK - at this point:

  • Disconnect main router
  • Only connect to LAN the device you're gonna use to setup the OpenWrt
  • Reset the device (Wiki, see: https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset)
  • Setup LAN as no DHCP and with IP of 192.186.1.2 then Apply
  • :warning: Within 90 seconds, browse to 192.168.1.2 or make sure you hit Apply Unchecked (or else it will revert back to .1)
    • Your device used to configure will need to have a static IP (e.g. .3), or not loose connection!
  • Connect main router's cable to another available LAN port
  • Setup WiFi
  • Done

Don't forget these additional 2 IP configs on LAN setting for an AP/extender:

I disconnected the main router and connected my macbook to one of the lan ports.

I held down the reset button until the green power button flashed a lot and then pressed it again and now it's flashing orange even faster.

I assume now failsafe mode has been triggered. The page you sent says it will boot with an ip of 192.168.1.1/24 but I tried both of them and it's not letting me connect. What do I do from here?

Edit: my network settings still say that there's no router ip.

You want to Reset, not failsafe. It should boot back to a default OprnWrt like when you first installed it. Follow all steps from there.

Simple.

No clue what this means, you haven't reset yet - or haven't told us.

It's assumed that when a Wiki link is sent, you'll at least read over the relevant section.

Ok I reset it and continuing from there.

When disabling DHCP, do you mean Interfaces -> LAN -> DHCP Server -> Ignore interface?

1 Like

Yep, that's the web GUI way to do it. BTW, that's Step 8 in the Wiki instructions for how to use the web GUI.

:warning: Please be advised, if your Macbook doesn't have a static IP (e.g. 192.168.1.3), it may loose connection mid process because you're turning off the DHCP server giving it an address until you plug up the main router to start giving them again!

I'm in the same area but in General Settings this time. Is the IPv4 the one you want me to change? I tried setting it to 192.168.1.1 but it says "The gateway address must not be a local IP address." And for the DNS, do you want me to go to Adv. Settings and put in the same IP for "Use custom DNS servers"

@keina - I really advise you look at the Wiki on how to configure a device. I thought this was covered. See: https://openwrt.org/docs/guide-user/base-system/basic-networking

Then I would advise you not set the improper gateway or IP - and set them as noted. BTW, saying yes to everything that's already in a Wiki is kinda confusing.

Imma just screenshot, because I don't understand the difficulty/error:

screen227
screen228

If there's an issue with the Wikis, can you note the Step you're having an issue with, thanks.

:spiral_notepad: I also hope you heeded the warning about the Macbook and connectivity to 192.168.1.2 after hitting Apply - before connecting the main router.