Using router as access point - no internet from router, clients OK

I have 4 routers set up, one is the real router, the others are access points (connected via the LAN ports and not the WAN port).
The router and access points are all running openwrt.
Everything is working fine, but when I try to access the internet from an access point login (trying to opkg update) I get no connection.
Not sure what to post to help with debugging... Any help would be great!

Side question: What AP's and router do you use? I'm looking for some AP's my self.. :slight_smile:
Did you follow the dumbap guide?

I am using four TP-Link Archer C2600's. I started having one as spare on a shelf, but added more and started using them. They are pretty powerful and relatively cheap used.

I'll take a look a the guide again, but as i said, everything else is working fine. I just want to be able to update my packages on the access points.

The guide didn't really help. In fact, I may have hosed things up a bit as I cannot ping any internal hostnames any more (IP is still OK). I still cannot ping outside of my network.

You could do the full steps of the dumb AP of you want, but the main things are:

  • make sure IP of the AP is on the same subnet as main router (but different IP of course). So if main router IP is, make AP for example.
  • disable DHCP on AP
  • Leave DNS and default gateway blank for the AP (or if you must, set the gateway as the main router's LAN IP).

These are all set and my wireless clients are working fine. I am trying to be able to ping from the access points's command line. I don't understand how the clients work fine but the AP itself is not connecting!

For some reason, I think this is a routing issue on the access points, but I really don't understand routing!

In addition to what mhegab writes;
I have a similar setup and in order to get access to the internet for my AP client i have to enter the IPv4 gateway address and the Use custom DNS servers on each AP. Normally they both point to the router address ( in my case).

1 Like

Absolutely correct Jack007!

Genius! that did the trick! Thanks very much!

The same goes for IPv6/ odhcpd as well, which also needs to be disabled (but is often forgotten).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.