Anyone with experience setting openwrt for use with highland broadband fibre connection?
It is using PPPOE as connection, does it use a plan tagging for that connection?
Anyone using VOIP with this setup using a VOIP client device like Grandstream HT801? Does it need changes in the openwrt firewall to make this work?
Can you post a picture(s) how vlan/pppoe/voip config looks in original CPE?
Wait, the Scottish Highlands has fibre? I thought messages were still transported by way of haggis along the single-carriageway A96.
Have a look in the wiki,
https://openwrt.org/docs/guide-user/network/wan/isp-configurations#fibre_optic
While it may not answer your question directly, it can provide some guidelines.
It would be best to ask your provider for the exact details so we can help you more.
They are on the B842. However us canny Scots make the best of the haggis flocks. With the new sporran adaptor, we can get one haggis to carry 25*1TB memory sticks so the bandwidth is pretty good, although the latency is often around 10 days.
With a flock of 100 haggii, do the math... not bad
Well, w are trying to teach haggis to talk here.
Thankfully the whisky-fuelled hagii between our house and cell tower don't seem to alter our 4G stats too much:
LTE | rssi: -50.00 dBm
| rsrq: -7.00 dB
| rsrp: -74.00 dBm
| s/n: 25.80 dB
And thanks to the net neutrality provisions imported into UK law precluding an operator from dictating use of particular terminal equipment, this canny Scot can make use a regular mobile phone contract SIM in an Zyxel NR7101 to satisfy all household internet requirements.
You must be using the fourth generation, specially bred, flying haggii, fitted with malted ethanol afterburners to optimise latency. Short range but very effective technology.
So the haggis seem to have its reputation spread around the globe.
Back to the original question: The answer is that the ONT unit installed by HighlandBroadband handles the PPPOE and CHAP authentication. All that needs to be done to get an openwrt based router to connect to it, is to set it in DHCP mode and connect it to the 10G network port on the ONT. Did copy the MAC address of the original HBB router into the openwrt router for the WAN network port.
The HBB router runs openwrt with a layer on top of it. You can ssh in the router and use:
show config network
and
show config firewall
to get the bits you need.
Use the WAN config interface wan section and the ipv6 firewall rule to make your router work on the OTN. Skip the
option cwmp****
parts in the wan definition in the network file.
Lots more definitions in network and firewall file that are not relevant to use on standard OpenWRT implementation
I've added the relevant sections of the openwrt config files too, including making ipv6 work with their setup. If you don't want to use ipv6, simply turnoff wan6 in the network -> interfaces menu, this also disables local ipv6 use. Make sure you don't lose your own additions in the config files when pasting these sections into your config file.
Note that the lease time ip the ipaddresses provided by the Highland Broadband servers are set to 600s, so the wrt router starts asking for new addresses every 5 minutes. Don't know why they've set that low lease time, did not get an answer on that when I contacted about it.
network file:
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr your 'router ip address'
option netmask 'lyour local ipmask'
option ip6assign '64'
option ip6ifaceid '::99'
list ip6class 'wan6'
list ip6class 'local'
option delegate '0'
option ip6hint '5'
config interface 'wan'
option device 'eth0'
option proto 'dhcp'
option peerdns '1'
option mtu '1500'
config interface 'wan6'
option device '@wan'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option norelease '1'
dhcp config file sections:
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
list notinterface 'wan'
list notinterface 'wan6'
option logfacility 'KERN'
list interface 'lan'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option force '1'
option dhcpv4 'server'
option ra_useleasetime '1'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
option ra_maxinterval '1200'
option ra_lifetime '3000'
Firewall config file sections:
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
list src_ip 'fe80::/10'
option src_port '547'
list dest_ip 'fe80::/10'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.