Using OpenWrt TD-W8980 as DSL Modem

Hi!
As said above, I want to use my TP-Link with Openwrt as DSL Modem. I read through some articles, but I just don't get it to work.
My test setup is a TP-Link (currently with th 19.07rc) and a 18.6-flashed FritzBox 7360, both, lantiq devices.

I currently have a working VDSL Telekom PPPOE connection on the 7360, but because I recently got 100Mbit instead of 25 I want to replace the 7360 with something more powerfull, because it can only manage about 60Mbit/s

The following things I tried :
I created a new VLAN on the 7360 switch with vid 2 and connected it to port 4 on the switch as untagged. On the TP-Link I although created a 2nd vlan with same settings. I also created a new interface on the TP-Link and bridged together the vlan 2 switch with the dsl0.7 modem named MODEM. then I changed the physical interface from my wan connection from dsl0.7 (VDSL needs VLAN id for PPOE) to eth0.2 switch. My thought was that the 7360 will send PPPOE packets untagged on port 4, the tplink gets them on its port4, forwards them to the dsl0 port and adds vlan tag 7, but it doesnt work. I also tried to set port 4 (in the switch configuration) on both devices to vlan 7 and tagged, but i still cant get a pppoe connection. When trying to establish a pppoe connection from the 7360 i can see on the interface tab on the tp-link, that the MODEM device receives packtets, but does not send anything.
I found WAN DSL bridge mode, but did not quite understand which settings are neccessary. Can anyone please point me in the right direction? Thanks!

Did you mean the TD-W8980?

Configuring a WAN bridge on the TD-W8980 between dsl0.7 and eth0.X is the right idea.

Please post the contents of /etc/config/network from both devices, and the output of running /etc/init.d/dsl_control status on the TD-W8980.
Screenshots from their LuCI switch configs could also be useful as an addition.

Hi! Yes, it's the TD-W8980, mixed it up somehow.
The FritzBox serves a WLAN which IP range is different from the LAN, and I just saw that I have bridged the WLAN to a LAN port, I'll try without that bridge again.
To test I just changed the pppoe interface from dsl0.7 to eth0.2.
Thanks!

System
Hostname : DSLModem
Model : TP-LINK TD-W8980
Architecture : xRX200 rev 1.2
Firmware Version : OpenWrt 19.07.0-rc1 r10649-c4fdb377a2 / LuCI openwrt-19.07 branch git-19.309.76540-c0e73d3
Kernel Version : 4.14.151

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd1:c489:3b04::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option firmware '/lib/firmware/vr9-B-dsl.bin'
	option ds_snr_offset '-20'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'wan_dev'
	option name 'dsl0'
	option macaddr 'e8:de:27:58:de:29'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '6t 5'

config interface 'modem'
	option proto 'none'
	option type 'bridge'
	option delegate '0'
	option force_link '1'
	option ifname 'dsl0.7 eth0.2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '6t 4'
	option vid '2'

DSL status (both routesr are using same firmware from latest FritzBox 7490 and get about the same VDSL link speeds)

ATU-C Vendor ID:                          Broadcom 193.218
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.9.1.4.0.7
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.5 (VDSL2 with down- and upstream vectoring)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 11
Errored seconds (ES):                     Near: 17356 / Far: 31
Severely Errored Seconds (SES):           Near: 216 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 2 / Far: 0
Unavailable Seconds (UAS):                Near: 3673 / Far: 3673
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 6119 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency [Interleave Delay]:               0.14 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 105.515 Mb/s / Up: 33.736 Mb/s
Line Attenuation (LATN):                  Down: 17.9 dB / Up: 17.6 dB
Signal Attenuation (SATN):                Down: 17.9 dB / Up: 17.3 dB
Noise Margin (SNR):                       Down: 2.0 dB / Up: 6.8 dB
Aggregate Transmit Power (ACTATP):        Down: 5.0 dB / Up: 14.4 dB
Max. Attainable Data Rate (ATTNDR):       Down: 98.467 Mb/s / Up: 36.088 Mb/s
Line Uptime Seconds:                      12833
Line Uptime:                              3h 33m 53s

switch config (not connected right now but shows link when port4 of both routers are connected)


interface config

3

FritzBox 7360:

System
Hostname OpenWrt
Model 1&1 HomeServer
Architecture xRX200 rev 1.1
Firmware Version OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.170.32094-4d6d8bc) 
Kernel Version 4.9.184

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd6:608c:c520::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option firmware '/lib/firmware/vr9-B-dsl.bin'
	option ds_snr_offset '-40'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.42.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option dns '127.0.0.1'
	option ifname 'eth0.1 tap0 tap0'

config interface 'wan'
	option proto 'pppoe'
	option username '##############@t-online.de'
	option password '#####'
	option ipv6 '1'
	option ifname 'dsl0.7'

config device 'wan_dev'
	option name 'dsl0'
	option macaddr '24:65:11:97:f8:8e'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 2 4 6t'

config interface 'LAN2'
	option proto 'static'
	option type 'bridge'
	option ipaddr '192.168.43.1'
	option netmask '255.255.255.0'
	option ifname 'eth0.7'

config interface 'vpn0'
	option proto 'none'
	option auto '1'
	option ifname 'tun0'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '1 6t'

Try option vlan '2' (make the vlan numbers consecutive).

I believe this part of your config should work. Here is mine, just for reference:

config interface 'modem'
	option type 'bridge'
	list ifname 'dsl0.7'
	list ifname 'eth0.7'
	option macaddr 'e8:xx:xx:xx:xx:xx'
	option proto 'none'
	option auto '1'

Using eth0.2 is also fine, it is not necessary to have VLAN ID 7 on both sides of the bridge.
However, if you do decide to use VLAN ID 7, you must change the VLAN ID of the LAN2 interface to something different.

Some further ideas:

Set up PPPoE on the TD-W8980 temporarily to start with a simple, working configuration:

config interface 'wan'
	option proto 'pppoe'
	option username '##############@t-online.de'
	option password '#####'
	option ipv6 '1'
	option ifname '@modem'

Get the current switch and bridge configuration from both devices:

  • swconfig dev switch0 show
  • brctl show

Disclaimer: I have not tried OpenWrt 19.07rc yet, my experience is based on 18.06.

Update:
Your DSL configuration differs between the TD-W8980:

and the FritzBox 7360:

I cannot say which one is correct (I am using ADSL2+ here), but you might want to reconcile them.

Hi!
Sometimes it's the small things..... changed

option vlan'3'

to '2' and everything works as expected.
Whats the difference between VID and VLAN? Is VId only the index for the VLAN and not the VLAN ID itself? Before tinkering around I had antoher VLAN added on the switch of the 8980 as VLAN2, bridged with the WLAN to still use it as an Wlan AP, and VLAN 3 for my PPPOE DSL experimenst. I removed both via Luci and added back only VLAN 2, but it seems the former VLAN 3 was kept somewhere. Now I can continue my plan to run OpenWRT as LXC container on my proxmox host and use the router as DSL MoDem and wireless access point. Thanks a lot!!!

I think it’s the other way around. The tag defaults to the VLAN option and can be explicitly set with the VID option. The VID option and a low-numbered VLAN option seems required for tags over the “table size” of the switch driver; for example VLAN 500 on a device with a 16 or 128 limit in the driver.

1 Like